Launchpad mini MK3 Problems

Haven’t seen this exact problem here on the forum so here goes:
I tried to set up launch pad with midi remote. Midi remote “hears” the built in function keys ex Drums, Keys, and User but cannot hear the 64 pads.

I decided to drop back and try the legacy generic remote. This works fine in cubase 10.5 but does not work in 12.

When I press the drums, keys, or user button I can see midi in activity on the midi in monitor at the bottom right of cubase but no such activity when pressing the 64 buttons. Midi thru is set to on in the preferences.

Cubase 10.5 still works fine so I don’t think the problem is with the launchpad.

Any suggestions would be appreciated. I’m stumped.


Does Launchpad mini MK3 send all MIDI data over the same MIDI Port? Or does it send the drum Pads data via other MIDI Port than the rest by any chance?

Thanks Martin. You solved it. I had the wrong port assigned. Apparently, the port assignments did not make it over with the upgrade. Thanks so much for pointing this out.