Layout is inly showing first flow on print page

I am trying to print three flows in a layout, and for some reason that particular layout is only showing the first flow. Does anyone know what setting I must have done to make that happen? Other layouts are showing all the flows. Thanks! All the layouts are checked in the setup page.

In Print mode, if you select that layout in the list on the left, is there a page range or flow range set in the Print Options panel on the right?

If not, then an alternative option (admittedly something of an unlikely curveball though): is your 1-flow layout using a page template set that’s only got one flow checked in its music frame chain?

Thank you-I had only the first flow selected in the print range. Didn’t remember that was an option!