LE 5 won't record

My setup:
I have my guitar plugged into a Tascam us-800 plugged into my Toshiba Satellite laptop with a Windows 7 64 bit operating system.

I got everything set up and things were working fine. I recorded a few tracks and all seemed like it was going to be hunky dory from then on out. I started getting busy so I didn’t have time to record anything for a while. After a couple months, I went to go record something again, but I couldn’t.

I get sound from the headphones from the Tascam. I can load a sound file into Cubase, play it back, and hear sound from it. I can’t hear any sound from a previously recorded track. I get audio activity on the right default input channel bar in Cubase when I strum the guitar, but I don’t get any activity from the main mix output channel.

I have the Tascam driver set as the ASIO driver; I have it set as my default playback on recording driver on Windows; I have double checked the VST connections to make sure the audio device is set as the Tascam us-800 driver; and I have followed the instructions in the “how to” thread that is locked in this forum.

I’m not sure what else there is to try. Any suggestions?

The monitor button has to be disabled to hear playback and enabled to hear live performance/ recording.

It doesn’t work whether the monitor button is on or off. Any suggestions on the recording issue?

Check the routing of the individual channels.

The channels are fine (unless I missed something).

Update: I found that if I switch the ASIO driver to default I can hear previously recorded tracks, but it comes through my computer speakers instead of the interface.

Edit: Okay, so I magically got it to record again. I’m not sure what I did. I found that if I have my previously recorded track open then it won’t let me record. I’m not sure why exactly. Could it just be that the track that I recorded before was just corrupt?

Edit Edit: Never mind, it just stopped working again… This thing just decides to work when it wants to I guess.

Here’s some links to some screen shots.

It seems I’ve figured out the problem.

On the VST connections I had the left and right mixed up on the device port. I tried it multiple times to see if it would just stop working again, but it has worked every time so far.

Thanks for the help.