License check times out in 80% of all starts, how annoying

I am having eLicenser since ages and Cubase (since version 1.x) started reliably.
Now with the new licensing the license check very often times out so that Cubase doesn’t start.
You get a popup window whether you want to repeat.
This is so annoying and even in the latest version I am getting these timeouts.
Cubase does not start reliably anymore, current version Cubase Pro 12.0.70.
Any proposal for a solution? Thanks.

The Elicenser is no longer used for Cubase 12. Could you give more details?

This post might be helpful as well, but replace the word “Elements” with “Pro” if that’s the one you use.

All my products are activated as you can see in activation manager:

I think/assume that this part has properly been performed when this change was made, its longer time ago. Its since the beginning that Cubase doesn’t start reliably anymore like before.
Now after Upgrade of Windows 10 to Windows 11 I am getting now the 1st time this message.
!deleted screenshot “No License Found”.
My computer is not yet prepared for dual boot again … so all that I can tell just right now, that I even am getting an additional problem after the Windows 11 update.
Can it be, that it is a problem, that I didn’t remove the eLicenser stick from the computer?
I hoped that keeping the USB eLicenser, that I would be more independend from internet access because I heard that you need to connect the computer at least every xx days, so that the software licenser is “satisfied”. I hoped for a permanent activation. Therefore I kept eLicenser plugged in in the hope that I am getting less trouble at all …
Now I get a message in the forum that a new user can only add one embedded media into a thread.
New user? How long am I Steinberg customer in this Forum. It is disgusting how the standard settings are and I hate this new forum, its a step back if it doesn’t work and need extra care to work properly. Why is always everything getting worse … things shall work, not fail or become more and more complicated …

You can post images now. Limiting image posting is an anti spam function. You now have the correct permissions here.

Thats great steve, many thanks.
And the License Problem is of all sudden solved and I really do not know, what the trigger for this was.
Another good but also astonishing thing, up to now (knock on wood) the timeouts during license checks on startup (for all the VSTs) also does not happen anymore.
I wished I knew what made this happen :slight_smile:
Not sure whether the Upgrade from Win10 Pro to Win11 Pro might have to do with it somehow, again triggering something (pure speculation), but I hope that this is entirely solved now.
Sorry, I was desperate yesterday and it nerfed already since the beginning, but never had time and fun to look at it.
At the end of the day … nice that it seems to work now.

1 Like