License reactivation problem

Hello, I have a weird license problem.

My laptop died (SSD failure) and I am reinstalling Windows and everything after replacing the drive. I installed Cubase and Wavelab fine, since the licenses are on the dongle. For Dorico I was using the soft-elicenser however, so I needed to “reactivate” it. So far so good, but on MySteinberg, it says I have a license for Dorico Pro 2. But I bought and upgraded to 3 and then 3.5, and entered the activation codes in my soft-elicenser, and was using Dorico Pro 3.5 until last week. Now the eLicenser has a 2 license and I can’t use the upgrade codes since they were “already used”.

I wrote on the FB group and John Barron suggested to register the codes in MySteinberg account before reactivating. I tried, but I cannot register them, if I enter the upgrade code for Dorico 3 it says “Activation Code not found. Make sure that the code has been entered in the eLicenser Control Center” and if I enter the upgrade code for Dorico 3.5 it says “The eLicenser assigned to this Activation Code is deprecated”. That’s because I guess I already reactivated the outdated Dorico 2 license so the previous soft eLicenser on my old SSD has been “deactivated”.

I guess I simply need to contact support, but when I try to open a ticket on MySteinberg, it says “Individual support for you is provided by one of our Steinberg distributors.” Maybe it’s telling me that because I purchased Cubase from Sweetwater in the US, but my Dorico licenses and upgrades were purchased directly from Steinberg. So who should I contact and how, to get this sorted out?

Thanks a lot!

It’s a bit odd that if you had updated to both Dorico Pro 3 and Dorico Pro 3.5 on your Soft-eLicenser, and that the eLicenser was correctly registered in MySteinberg, that it should only show you the Dorico Pro 2 license and not the subsequent updates.

Under normal circumstances you should indeed open a ticket via MySteinberg to resolve this, but since you’ve posted here, I can help you. I’ll send you a private message with the next steps.

Hi Daniel,

Yes, it’s a bit odd indeed, I didn’t understand exactly why that happened. In any case, thank you so much for answering this quickly, I am now back up and running, awesome customer support as always!!

As for the ticket via MySteinberg, indeed I would have liked to, but it was not giving me the option. It said “Individual support for you is provided by one of our Steinberg distributors”. My personal guess is that’s because I bought Cubase and Wavelab from a reseller, so my whole account is “flagged” as “support from distributor”. But Dorico and upgrades were bought direct from the Steinberg online shop, yet it was not giving me the option to open a support ticket (or I didn’t find it).

Maybe you could forward that to the web development team, that there should be a check first for which product the customer wants supports for, and then forward it to an internal ticket or an external distributor.