licenser, wrong version

There appears to be a miscoding of the link to the latest eLicenser Control Center here: it’s supposed to link to version

Version**4** is what actually downloads.

Is the later version available elsewhere, please?


That very download link has just installed here.
Is there a chance that you’ve downloaded the latest version, then run a previous installer that happened to be lurking somewhere on your computer?

Hi Leo - no, I tried several times, refreshed and cleared cache. I keep getting the old version when it downloads.

No old versions in my /Applications folder :slight_smile: Thanks!

Just SHIFT-Reloaded and tried again. Still the old one - see grab…

Hi Mark, I clicked on the link (Download latest e-licenser Control installer) in the Help section of the e-licenser control centre and I’ve successfuly downloaded and installed .65.

Thanks, David and Leo - in the end I had to ‘change my location’ by switching to another server in my VPN network.

That got the .65 for me.

So I assume it’s a propagation issue on the Steinberg external network.

Your help appreciated :slight_smile: