Listen Fx button not working properly in Cubase Pro 12

For example, when I create an amp send fx to a bass track, I was able to hear the only fx channel by pressing the L button in the mixer before. However, idk since when but it started to not work correctly and all I hear is the source dry bass audio.

image
image
image

I already setup my audio connections and control room long ago according to this video and other helpful videos https://www.youtube.com/watch?v=oz83ocFmJQs which is a little outdated so I made sure from Studio > Audio Connections > Outputs not connected > Control room enabled & left and right channel properly selected to my interface.

Like I said no matter what kind of fx I insert (pre or post insert) on the bass amp fx channel I want to solo, I don’t hear any fx at all. I also changed pre or post fader send but nothing seemed to change.

When I solo the amp fx using the S button in the mixer, I finally can hear the amp fx with the source material together but it’s not ideal for adjusting the amp fx sound. I only want to listen to the fx audio.

Someone tell me what is wrong with my setup or what I’m missing in this case please!

P.S.
I updated Cubase to the latest version yesterday, but this function has been failing since months ago to this day.

Have you also checked the Listen settings in the control room channel?

Maybe Listen Level is turned down.

2 Likes

Hello fese, thanks a lot! You saved me!

I almost forgot that control room also has main tab, and as soon as I switched this PFL thing
image
to AFL
image

now I can listen to fx channel only.
What a noob mistake that I’ve made. Thank you so much!