Lock note values on rests

Hello, how do I get my desired rests?:
Original.png
In Dorico I so far can only get this:
Dorico.png
I tried to lock note values, but it does not seem to effect the rests…

I think it would be “force” note value (O), not lock, that would work.

Indeed :
Force duration.png

k_b, there is an option in the rests section of the Notation options, where you can tell Dorico not to use dotted rests. Very comfortable …
Heiko

HeiPet,
thank you, I tried these options, but they don’t work in this case (at least not in this case):
Notation Options - Rests.png

Yes Marc, this actually works, thank you!

Ok, I tried it all with key commands, still one question:

After hitting the comma for inputting rests, which key should be pressed? can’t find the „any“ key :wink:
Original.png
Key command sequence to get the upper example engraved:

„SHIFT-N“

„6“ „.“ „G“

„O“ „,“ „.“ „G?“ „5“ „G?“

„SHIFT-D“ „P“„P“ „ENTER“ „O“

„,“ „6“ „.“ „A“

„O“ „,“ „.“ „A?“ „5“ „A?“ „O“

„,“ „6“ „.“ „B“

„O“ „,“ „.“ „B?“ „5“ „B?“ „O“

„SHIFT-H“ „f“„e“„r“„m“„a“„t“„a“ „ENTER“

„SHIFT-N“

47 keystrokes for 3 notes, that is quite a lot. Is there an easier way? …

Result:
[attachment=0]Dorico notation.png[/attachment]

Dorico notation.png

In my older type-based engraving system I had to do 31 keystrokes for this, well, 43 counting the space key… But all codes where placed so well it only too seconds to enter something like this:

G4. p4 p8 pp A4. p4 p8 |
B4. p4 p8 fm p2. |$

I’m sure you will get more efficient after some 1000 bars or so…
If you type a lot on keyboards you will by time not even look at the keys, and it will just flow…

Press any of A to G.

I did it and it was quite fast… It might be faster to write it the Dorico way and come back to the dotted rests to correct them as you wish, I don’t know. Maybe Daniel has the trick to make those dotted rests go away for good.
Reading carefully what you did, I do not understand why there are so many times the “force duration” command. It could remain for the whole process… You would gain some keystrokes :wink:
And for the fermata… it’s faster to click on the icon !

You’re right. Haven’t tried the options in in a 12/8 meter before. Doesn’t work as expected for my either.

Marc, I am trying to avoid the mouse (Sib. handbook „hide mouse in a drawer“).
Of course I can correct the dotted rest in a second run, I would need the mouse there too (to toggle the switches).
Or, as you mentioned, leave the „Force Duration“ command on all the time…
…just trying to be efficient.

Dear k_b,

I understand perfectly your search for efficiency. I think the only way to spare time here would be that Daniel and his team would add a working option to get rid of the “quarter” dotted rests (don’t know the name in English. In french it would be “soupirs pointés”) so that you could write in a real flow. In another thread of yours, I told you a also agree that fermatas inserts is really too long with the keyboard and we could expect an improvement here too. Thanks for these threads, hope Dorico’s team will have a look at it ^^

I’ve set the Note Options for rests to disallow dotted rests and also tried locked note value for the rest and I am still getting a dotted rest. It will not allow me to enter half-rest, quarter rest, eighth rest and 2 sixteenth notes.
Untitled-1.png

Dear EMF,

That’s funny… I tried to write down the same rythmical example and I got directly what you are looking for !

I entered the rythm once using the caret, the right arrow until the last 8th and added the two 16ths notes. As it gave that result, I canceled everything and tried your way, inputting three different rests and two 16ths notes and it gave me the same output.
Capture d’écran 2016-12-01 à 19.14.17.png

I went back at the offending bar and this time, clicked the dotted rest, got the carat and then

  • forced duration
  • selected quarter note
    The dotted rest disappeared!

I had set layout to disallow dotted rests from the beginning, which is why I was so puzzled.

Is it possible that not all the “Notation Options” are implemented yet? (If so, I’ll wait patiently, and use Force Duration in the meantime.) I’ve set the option “Notes starting after the start of the bar of multiple beats in duration” to “notate as single note.” (Essentially, as in the example provided there, it allows the writing of a half note beginning on beat 2 in 4/4, and presumably similar-looking meters.)

I’m inputting a Bach keyboard composition in cut time, and every time I try to create a half note beginning a quarter into the bar, Dorico creates two tied quarter notes instead, which seems contrary to the option chosen.

In 2/2, however, a note that is only a half note long is not multiple beats in duration, since it only adds up to a single beat, so the option doesn’t apply, I think.

Ah, true. So it is indeed consistent (which is a GOOD thing). And as a music theory professor, I do understand about making the middle of the measure clear in this sort of meter. But a quarter-half-quarter pattern is so common and basic in this meter, it seems a trifle odd to have to treat it as an exception, to be handled with Force Duration. Still, I can get used to it, I guess. Thank you, Daniel.