Lockups with plugins on multi-screen configuration

I am having significant issues with plugins and Cubase freezing for a range of plugins when used on a multi-screen configuration. Cubase Pro 10.0.20 on Windows 10 Pro x64 (1903) with nVidia GTX 1650 graphics connected to Dell P2314T MultiTouch 1080p (DisplayPort) monitor set as primary and Dell U3417W UltraWide 3440x1440 (DisplayPort) set as secondary monitor. With 100% scaling on the 1080p and either 100% or 125% scaling on the UltraWide secondary monitor, I face the following problem with Arturia V Collection 7 (and previous ones, since their scalable UI was introduced) as well as the MasteringTheMix plugins LEVELS and REFERENCE:

  1. Add/open VST on primary monitor - all ok

  2. Move to secondary monitor - all still ok

  3. Move back to primary monitor - all still ok

  4. Close on primary monitor - all ok

  5. Reopen and retest - all ok.

  6. Add/open on primary monitor - ok

  7. Move to secondary monitor - ok

  8. CLOSE on secondary monitor - appears to be ok

  9. Open again, opens with blank edit area - moving to primary monitor does not help

  10. Try to close, it freezes Cubase completely, needing the process to be killed! Because it is killed, no crash dump log available.

  11. After restarting Cubase, try to add/open again, and now it tries to open on second monitor with problems as per step 9.

  12. Only way then is to kill Cubase, disable extended screen mode, launch to get it back on primary screen, and then close it in that mode.

Have been working with both Arturia and MasteringTheMix but have not been able to get it resolved with them. The issue does not occur on REAPER, but does (but without the issue of having to kill the process) in Cakewalk/SONAR Platinum. Not tested in others, but seems to be something to do with the initial drawing process when on the secondary screen. As its more than just one plugin manufacturer, is this something Steinberg can/should be looking at?

Interestingly, MasteringTheMix use OpenGL in their plugins - not sure about Arturia, but I suspect they might also be doing the same. Have also had issues with Cherry Audio’s Voltage Modular when it is configured to use OpenGL - so there appears to be a conflict going on between OpenGL in Cubase and the plugins.

An update after some further research - looks like Waves plugins, which also apparently use OpenGL, seem to also suffer from the same issue. And just also tested a new plugin from MasteringTheMix that is NOT OpenGL based (BASSROOM) and which works fine… so all things pointing to this being an issue with OpenGL based plugins on multi-screen monitors (maybe specific to the Intel and nVidia drivers as have not tested with an AMD GPU) when instantiated from Cubase.

Sorry for bringing up such an old thread, but I’m having exactly the same problem, and it’s driving me nuts. Did you ever find a solution to the problem?
I have the same graphics card as well.

This is happening to me as well, EXACTLY as stated, in my case I can confirm also happening with Nugen plugins.
I do believe it might not be Cubase’s fault, because when testing the standalone versions of Nugen plugins, it still happens. With Waves plugins instead, the standalone versions seem to be working fine.
The odd thing is that before reinstalling Windows, everything was working perfectly fine. It’s like an update of Windows broke this function? Why isn’t this happening to everybody?

Maybe this is my issue? I have 4 monitors (just added the 4th) have gui problems on my control room inserts. I will try disconnecting. Monitors 1 by 1 and see if that helps my problem

I, and another studio owner I know are both having this issue. New build AMD based system (12 core 3900x processor, Asus motherboard and GPU Nvidia card). Was there ever a resolution to this?

Hi guys, I just created an account here to post a possible solution. I had the exact same problem with other DAWs (I am not a Cubase user) and found this thread about it. But I also found another one:

There is the solution posted, that “Nahimic” needs to be uninstalled. In that thread only MSI boards are talked about, but it can be part of other onboard audio drivers AFAIK. I also had that software on my machine and after uninstalling it everything is fine. Maybe that helps!

1 Like

Hey guys, same issue here. Experienced the issue just now with a new plugin I bought (Gullfoss) and I’ve reported it back to the vendor hoping they can shed some light on this.

I have a 4-screen setup where a few plugins freezes when the UI is opened up on a non-primary monitor. This does not seem to be HW related though. My build is a Asus MB with i9 CPU and Nvidia RTX 3080 GPU (also reproduced on a GTX 970 card) and people are reporting the issue with all kinds of HW setups.

Funny part is; I’ve seen the exact same behaviour with Native Instruments download client (Native Access) (Cubase was not running). So, to me it doesn’t seem to be related to Cubase either. I don’t know, but to me things are pointing to the library used to render the UI and is independent on HW except for multiscreen setup. Whether this is OpenGL or something else, I have no idea.
I know this wasn’t very helpful but perhaps could point someone in the right direction.

Thank you SOOOO very much Danam!!! New build here, and facing the same issue and symptoms as OP, only differences being the DAW (Reaper) and the faulty VSTs Waves and the MB (ASUS CHVIII). Thing is that the MB also came with some obscure audio programs, and uninstalling them did solve the problem!
Your post really saved my day, so I created an account here just to express you my everlasting gratitude! :slight_smile:

Yes, thank you Danam ! I had a similar problem with an Arturia VST (Pigments) and Cubase (but also with Cakewalk). The VST always crashed with 3 screens (but not with 2). The VST window was empty (blank screen) and it freezed my DAW. I have a RTX 2070 with the latest drivers so I couldn’t believe the problem came from my graphic card. So I just looked at the “Nahimic” issue… I observed that the process was running in background (I’m a Windows 10 user) and I just deactivate the program (didn’t need to uninstall). Here is what I did if it can helps someone else who has the same issue :

  1. Verify if the Nahimic process is running on your computer : Task manager (Ctrl + Alt + Del). You should see a few .exe files running.
  2. If it is the case, type “msconfig” in the Windows start search bar, go to “Services” tab and uncheck the box for Nahimic.
    That’s all !
    I restarted my computer to be sure, re-opened Cubase and it worked ! I guess it will be the case with other plugins using OpenGL). Now I can run Pigments in my DAW with 3 screens (which is sooo confortable to work with) !
1 Like

OMG guys THANK YOU for sharing this solution!!! :smiling_face_with_three_hearts:

This problem just started like two week ago or so and I can not exactly recall what installed NAHIMIC, was it part of a Windows update? But deactivating it FINALLY solved the issue which was mainly affecting only my WAVES plugins I believe. I actually updated from version 10 to 13 hoping that would do it but same problem. Luckily they had a sale going on so wouldn’t cost me that much.

HI all, a friend of mine asked me to help him with the issue of waves plugins crashing on launch whilst using dual monitors. No errors just a screen freeze.

Cubase 6.5
Windows 10 pro
Asus rog strix b550
evga 1060 gtx
ryzen 9 cpu

Here’s what I found:

This issue arose after upgrading the motherboard to Asus Rog strix B550, as part of its own software there is a package called Sonic Studio Virtual Mixer, guess what…? sonic studio is created by the good old NAHIMIC company you will have seen whilst trawling forums looking for a fix.

Switching off ‘fast boot’ in the bios settings has been an option for a fair few users but if you would like to remove the driver completely press:

Windows + X > Device Manager > Expand sound, video and game controllers > Right click Sonic Studio virtual mixer > Uninstall.

Hope this helps, don’t do anything you’re not capable of and have fun.


Updating thread for 2023. Thank you for posting this solution!!! Disabling Nahimic did the trick on my new build with Intel 13th gen, Nvidia 40-series, and Asus Strox Z790 motherboard running Cubase 12 Pro.

Asus did include Sonic Studio app, but I haven’t needed to remove it yet as the Nahimic fix worked perfectly.

Thanks again!!!

Adding to this!

I have an I7 13700K, 32GB ram, and Nvidia 2080 Super.

I have been chasing Waves support and getting SO upset. All was working fine inside a medium project of mine, until all suddenly froze.

Today i disabled all secondary monitors, and the project opened fine. But if a plugin opened / started on a secondary monitor, taskmanager and force-quitting was the only option.

Disabling Nahimic fixed ALL of it.

Just too bad i was convinced i had to upgrade Waves 12 to 14 for 160 dollars 1 hour earlier (wich ofcourse made no difference)

Finally! Thank you! Disabling Nahimic worked! Only took an entire year to find the solution.