Lofi piano missing

Hello I’ new here , sorry in advance for my poor english.
I installed the free lofi piano.
Donwload assinstant ok.
License ok.
Librarian manager ok.


Then halion sonic 3 dowsnt show the lofi piano. I see HSO, the Olympic choir, etc, but not the Lofi piano.
Someone else with the same problem?

don´t search for lo-fi, go to the Halion Media Bay, it´s there with all other libraries

Thank you
see the images: ok i DO NOT have lofi pianos in my media bay nor the library on image below.
Understand me, i DO NOT HAVE the library, the image below is taken by youtube and is as have to be:


I have lofi piano in my library manager, i reinstalled and both times it said "installed succesfully

I have the same issue.

I get this error when opening Cubase.

I have tried removing the product and re-installing it, but issue persists.

You need to download it from Steinberg web, not from SDA. So go to web, log in and download it. Then you will be received the code for download the product and all will be good!

1 Like

As @Alexander_D says, you need to get a free licence from the Steinberg website (click).

Same problem here.Installed wia download manager, then installed id, Librariy manager shows it, but I can not see it in H.alion

Update Halions and find the code in MySteinberg account

I’ve the same problem. I installed LoFi piano, re-installed Halion, used codes sent to me, but I can’t see LoFi piano in Halion.

I use the Download Assistant to download the Lofi Piano in Cubase 10.5. Everything went smoothly. Download ssistant said it was successfully down loaded. Lo-Fi piano does appear as one of the programs available to load in Halion. However, individual in pianos will not load.

Is this vapor ware?

It isn’t vapourware, but it does require:

If I remember correctly, the Steinberg website emails you a Download Access Code - you can redeem that for a licence using Steinberg Download Manager.

LoFi Piano is working correctly on my system.

thanks all for reply
it’s simple… i didnt remember that after download and activate the key i need also register it in key licenser… effectively is a bit complicated… when yyou dont install new sw frequently, it s easy to forget…

[My vaporware comment was a joke.]

I’ve been trying to download the lo-fi piano for the last couple of days. I have had no luck. I did take the following actions in my attempt to download the Lofi Piano.

  • Obtained the Steinberg website email Download Access Code
  • Redeemed the Download Access Code using Steinberg Download Manager.
  • Downloaded Lofi piano in the download manager.
  • Received message that software was updated to my account.
  • Checked to make sure Lofi Piano is reflected on my eLicenser. It is.
  • Used Halion Sonic 3 to access pianos. Pianos don’t load in Halion Sonic 3.
  • Also loaded latest version of Halion Sonic SE3 - and I still could not load the Lofi Pianos.
  • Note that I can see the pianos on the screen. They just won’t load.

I think maybe it’s time to give up…

kwill, i had similar problems as you. it took me a while to get it all sorted out. in the end, i had to update eLicenser, update HALion SE3, update eLicenser again (!), re-register the .vstsound file in Library Manager, etc ,etc. honestly, the whole thing was a huge PITA and took way too much of my time, but i finally did get things sorted and it’s now working.

hoping this might help you in your own struggles…

I have actually realized that I need to get a download code only via this thread.

However, when I oopened Halied Sonic SE 3 standalone app, the LoFi Piano still did not appear.
I should note that I also installed Novel Piano (which was also a free library from email from Steinberg before Christmas). Novel Piano appeared in instruments sets of Halion but LoFi Piano not.

After that, I started Cubase elements and created a project with Halion. Then the LoFi piano library was finally there.
Now it also appears in Halion standalone app.

l finally got in touch with email tech support and discovered that my problem was a Halion file that got corrupted by a recent upgrade. Here is the link to the instructions I received:


Finally. It looks like a lot of things can go wrong when you try to obtain free Steinberg software.

I received the activation code form the webite, downloaded Iconica Ensembles, but it did not show in my Halion sonic SE. I was stuck for hours and somehow got it to work…
Here is what I checked, hope it helps some people.

  1. Check eLicenser control Center. If your license is activated it should show on the list.
    Mine showed, but the lofi piano was still not on the list.

  2. Download Lofi piano from SDA. I don’t know but it shows download, so I did it.

  3. Check Steinberg Library manager and see if there is lofi piano.

For me, I think doing number 2 worked. I restarted the PC several times during this.
Again, I am not really sure why it works now. But sharing in case someone is stuck…
Although I got it to work, when I open Cubase 12 it still shows a message saying that the license for Iconica is expired.

I’ve managed to install Lofi Piano ok on one computer, but I wanted to install it on a second computer and I’m having problems with the soft elicenser. According to the support info:

“If you need additional installations in parallel on other computers, you need to purchase the required number of programs”

…since it’s free, I tried to get a second license here:

but that doesn’t seem to work. Is there any way to install it on two computers?

1 Like

In my experience, with these free items the ‘download for free’ link only ever sends you one license code and after that it seems to remember that email address and it won’t send you another one no matter how many times you click on it. With the VSTs by Cinematique Instruments (CI) such as Guitar Harmonics and Alto Glockenspiel I contacted CI directly and they actually provided me with additional eLicenser codes that I could use on extra machines. Not sure if you can do that with Lo Fi Piano as I don’t think CI are the orginal vendor. The easist thing to do is put the license on a dongle. Some other users may know how to go about an alternate route for getting more eLicenser codes for this one. You could go down the support ticket pathway I guess.

Thanks for the reply.

I really don’t want to go back to using the dongle so I might try contacting support

1 Like