Logic Doesn't Recognize Steinberg AU Instruments

Hi Folks,

I’ve seen other forum posts about this from last year, but I need help opening Halion Sonic 3 SE in Logic Pro X 10.6.1. I’ve tried all of the tricks suggested on the forums, and I can’t get Logic to register a Steinberg folder with Halion. Happy to post screenshots of anything useful. Thank you!

Are the Steinberg AU Instruments listed in the Logic Pro X Plug-In Manager and is their “Compatibility” status = successfully validated?

best regards

I tried it too, can’t verify halion and absolute package doesn’t work with Apple silicon m1 logic pro 10.6.1 on bigsur

Hi CubaseProUser,
in your case the “doesn’t work with Apple Silicon M1” is a most valuable information.
To my knowledge on Apple M1 Macs one has to launch Logic in Rosetta mode, after a successful validation of the Steinberg plugins it’s possible to quit and restart Logic in the “native” mode and the Steinberg plugins should run as expected.

best regards

Thank you, I tried the method you said verification succeeded but only Halion 6 and Halion Sonic SE also Halion Sonic appear, did not see groove agent and others.

This is where Apple comes into play, helping you and us to understand why successfully validated plugins won’t be listed in Logic.
Just to make it clear, we at Steinberg can’t do anything in this matter. You have to ask Apple about the progress. This issue is affecting other plugin vendors (e.g. Waves, Focusrite, Spectrasonics) as well.

This is something I found on https://www.logicprohelp.com. No responsibility taken, though!

None of my Waves plugins were showing after validation, in addition to several other workhorse plugins. This was scary, but it worked for me:

  1. Delete these:


  2. Restart Logic

Everything is currently appearing and will hopefully stay that way…

best regards

This is TERRIBLE advice, yes it got Backbone to show up but it has wrecked my plugin authorisation in Logic - it forced a re-scan of the entire AU collection but I am now plagued with non authorised AU’s that I can’t get Logic to ignore.

Why don’t Steinberg sort this out properly rather than cutting and pasting advice from a separate forum without checking it?? It isn’t happening with other manufacturers that I have experience of.

I can’t test this because I only own a few Steinberg plugins that came with Cubase and they appear to not include the AU versions at all.

I agree with you, I have not seen these kinds of problems with any other AU plugins, and I own hundreds of them… I’m kind of skeptical that this problem is apple’s fault…but anyway, if Steinberg can’t figure it out either…then that just sucks…

But what I can say is that I am able to host the VST3 version of Padshop in logicPro by using KushView Element.