Loop points

Is it possible to create loop points in a WAV file without also creating a region from the same selection? The software we use to process audio has issues with the region markers, and the only current workaround is to open the file in Sound Forge and remove the region start and end markers.

Not possible. Why is it a problem?

The proprietary software we use doesn’t play nicely with the region markers that are created. I don’t know the specifics as to why it’s an issue, but I simply know that it is.

If there was a new marker type that effectively did the same thing, but without creating region markers then that would be quite useful. Sound Forge has this functionality. They call it a Sustain Loop.

Hi PG. I’m the coder that works with dschreiberjr, so I can provide a few more specifics.

The problem arises when we use Wavelab (9) to add loop points to a WAV file. The output file contains the loop start/stop points in the ‘smpl’ chunk (as expected), but it also contains a 'cue ’ chunk with a single cue-point at the sample-index of the loop-start point (this is not expected). Note that this cue-point is not displayed in the list of markers in the ‘markers’ tab, and we can’t see any way to remove it in Wavelab.

Our software assigns special meaning to cue-points that the user places with the ‘Generic Marker’ functionality (which also save their data to cue-points), so the presence of this hidden cue-point causes issues with playback.

We can suppress the hidden cue-point by deselecting the ‘Write Markers in WAV File Header (RIFF Format)’ option in the File tab, but this also removes any intentionally-added Generic Markers that we need for proper playback.

Here’s some screen caps of our test-file with interior loop points:
http://i.imgur.com/QjsIbKe.png

and the File settings we’re using:
http://i.imgur.com/BQmd835.png

Is it perhaps a bug that the loop-start point is being redundantly saved as a cue-point? Or is there some way to suppress this behavior?

Thanks. :slight_smile: