Losing Piano sustain after recording

I’ve just bought a new keyboard NI A61 and noticed the same issue is happening in Cubase. when ever I record a piano part and use my sustain pedal, the sustain just disappears. I’m using The Grandeur and the sustain works outside of Cubase and it work inside of Cubase but 9/10 after I recorded a piece, the sustain is gone. I think it’s safe to say it’s not the keyboard and it’s not the program since…

  1. I have used two different keyboards.
  2. The sustain works inside and outside of Cubase prior to recording.

Does Cubase have it’s own way of dealing with sustain?

The A61 is going direct into my pc via usb cable and is shown in all the programs I use.


Double-check the Preferences > MIDI > MIDI Filter, please. Make sure, no Controller is filtered out here (enabled = filtered out; so disable the options), please.

I assume you mean the picture attached? Surely those things should be ticked by default?


Yes, I mean this. OK, this looks good.

Then could you please double-check Studio > Studio Setup > Remote Devices. Make sure all Remote Devices have set the Input to Not Connected, please. Especially, if there is Mackie Control.

Clicking on remote devices does nothing. I assume you mean Remote device sub folders, “Track quick controls” and “VST quick controls”? Both of those say not connected. “MIDI Port Setup”, only Komplete Kontrol A61 is active on the i/o In, nothing else.


Yes, I mean all the Remote Devices in that folder…

What do you mean by “only Komplete Kontrol A61 is active on the i/o In, nothing else”, please? Is it one of the Remote Device? Could you (for a test) try to set it as Not Connected too?

i/O Is short for input and output and the keyboard must be setup in there otherwise my keyboard will not work. It literally says it in the midi port editor in Cubase that Steinberg designed themselves. You MUST have something activated for it to work so the advice you are giving for me to set it to, “Not Connected” is wrong. I’m trying to give as much information has I can because this seems like a really slow process. I have already had abuse from one admin and I really appreciate the help but please, if you are unsure and do not work for support like the other admin didn’t, it is probably best to leave it to someone who can go straight to the issue rather than in bits. I know support is closed (I connected them over another issue 2 week ago with no reply) and forum moderators are asked to deal with issues but, you must understand how frustrating that is for paying customers left with half answers but no real solution. My issue is more about losing sustain after recording rather than the setup because it works properly prior to recording. Surely somebody had this problem?

Again, I appreciate the help.


Do you mean the I/O in the MIDI Ports Setup (then yes, sure, this as to be enabled; I didn’t talk about it) or something in the Remote Devices (I was talking about).

Anybody with the same issue I was having here is two pictures.
Make sure those settings are the same in the pictures but obviously you will have a different controller.

Anything you have already recorded may not have sustain so you may need to do one of two things…

  1. Put sustain in manually.
  2. Record that part again with the new settings.

To put sustain in manually you need to double click the midi part and you will see a keyboard on your left
under that keyboard you will see the work “Velocity”. click that word and a menu will open.
go down the menu and click on Sustain CC64 and a bar at the right will open like the velocity one.
Right click and press the draw icon and press once in the bar mentioned.
Now you have a line and that is how much sustain is going to be on.
click anywhere on that line and you can make a little box that can be pulled down so certain parts will not be sustained.
I will show another image so people can understand better.


In the Preferences > MIDI > MIDI Filters, you can enable SysEx. By default, the SysEx data is filtered out.