Losing pitchbend after saving midi project

Issue :

  1. Create new midi project
  2. Import a midi guitar track with several bending
  3. Play: it sound great!
  4. Save and close the project
  5. Open the previous project later
  6. Play: all the bending sound are lost!!

Please help, thank you

Hi and welcome to the forum,

Can you see the Pitch Bend MIDI data in the track, please?

Hello, thank you to reply.

Yes in the midi list editor I can see the pitchbend data correctly present with their value 8000+ both when initially I import the midi file playing good, and after when I save the project and I open it again but it plays bad like is ignoring the pitchbend messages.


Is it ignoring the Pitch Bend or is the range smaller?

Please, double-check the Preferences > MIDI > MIDI Filter. Make sure the Pitch Bend is not filtered out. By default only SysEx data are filtered out.

I can read sequences of pitchbend data with values from 8192 to 9557 which are looking ok. The MIDI filter is also looking ok, only active for SysEx data.
My current Cubase is Artist 12.0.52 (recently purchased…) and the midi file is generated through Musescore. In case I can send the test midifile for local replication testing purpose.


That might bring some light.

Please find attached the midi file as discussed.

Best regards

Brothers_in_Arms-lead guitar-Electric_Guitar_(Tablature).mid (3.73 KB)

After various trials, I found a way to enable again the pitchbend reproduction in the midi file:
the imported midi track is assigned automatically to a Halion Sonic SE3 guitar overdrive instrument. I opened the tab Options of the instrument and in the “Global” section there is a setting “Program Changes” set to “GM Mode”. I tried to switch it to “Off” and again to “GM Mode” and magically the pitchbend is working again! However I have to do the same procedure every time I open the project and this is very annoying. Maybe it can help to explain the issue?


I tried to import the MIDI file and the Pitch Bend works as expected immediately after the import. The GM Mode is enabled on my side.

Maybe you can try to trash HALion Sonic SE preferences. The Preferences folders are:
Mac: ~/Library/Preferences/HALion Sonic SE
Win: %appData% Steinberg/HALion Sonic SE_64

When you import the file it is working immediately also for me. But after I save and close and re-open it is not more working. Can you confirm if such issue is not present in your system?


You send some MIDI CCs, you are probably not aware of. When I deleted all init MIDI CCs (including RPN MSB and RPN LSB), the Pitch Bend works as init values (but other way, you expect). To me it seems, you set different PitchBend range (different from the default setup +/- 2 semitones), probably by the RPN CCs or SysEx message.

Your opinion looks very correct. I tried with other instrument (Komplete Kontakt which allows easily to change the PitchBend range) and I solved the issue there. I have just to understand now where soch parameter is wrongly set. Thank you very much