Lyric "no extender line" option not working now

From the manual.
Right arrow

What I get now
Now

But a previous version of Dorico gave me this
Previously
Is this an unintended change?
Andrew

I suspect the length of the line in your example is right at the minimum threshold that you have set in engraving options, and likely a small change in spacing bumped it below that threshold.

Well, thank you. I can get my desired result by changing that minimum value by a rather extreme amount, from the default 1 space to 5 and a half spaces.
As far as I can see there are not undesirable effects elsewhere in the project.

My point still stands, though. The right-arrow option is not working.
For that reason, I am reluctant to mark your post as a solution.

But that doesn’t make any sense. To display more extender lines, you would want to lower the value, not increase it.

Without seeing the project, I’m not sure I have any ideas.

In this case, I do not want the extender line and had to increase the minimum value to eliminate it. I should have been able to just press right arrow instead of space.

I think it might be the tie. In Dorico 4 & 5 if I enter a syllable on a tied note and then pressed the right arrow I always get the lyric extension line. Try undoing the tie, then entering the word then put the tie back. If I’m doing vocals I don’t enter ties during note entry. When I enter the lyrics I use the right arrow as you mentioned and don’t get extensions. Then I go back and add all the ties.

Thank you. The solution

I’m not clear: why don’t you want an extension on the tie? That’s entirely usual.

To my eye, with the extender there is not enough word separation. There is not an engraving option for shortening the line.
I have shifted the lyric a bit to the right in engrave mode to balance it…

I can’t answer for the original poster but there are quite a few situations where extensions aren’t used anywhere in a piece. I’m completing a hymn engraving project where I did nearly a thousand hymns and very few had any lyric extensions.

In that case you can “turn them off” in Engraving Options, by making the “Minimum length” 10,000 spaces. Or something.

I’d agree that perhaps the two eighths are a bit squashed, and you might want to do something to pull them apart. But your first example has enough of a gap to be obvious.

As a singer, I’m much happier with an extender going close to the next syllable than going without it.

In extremis, you can manually shorten it in Engrave mode. Or even remove it, if you must!

That works great if one’s workflow is only in Dorico, but if you have to export via musicxml, the extension lines are exported. One then either needs to manually edit the xml file or change all the extensions in the destination program. There are situations, admittedly not the majority and maybe not worth the time to implement, where being able to completely turn off lyric extensions would be nice.