Lyrics help

Hi, everybody,

I already addressed lyrics in this thread, but I think these questions are specific enough that a separate thread would be useful.

In the attached file (new page size & margins, new font), I cannot figure out what’s going on with the lyrics. If I select the first note in the score and then press Shift+L, the popup box shows up with a “1” meaning it’s for stanza 1. However, there is no text in the box. Why? This is what I see:
If I click, though, on the syllable “Pil”, the lyrics box comes up, has a “1” in it (stanza #) and has the expected syllable. Then I see this:

(1) What is going on?
(2) Corollary: Is there a way to click on a rhythmic position or note or something and see all the lyrics linked to it?

Other questions:
(3) Where can I change the character used for lyric hyphens? Since I changed the font to Crimson Pro, the hyphen is slanted. I’d like a flat hyphen.

I’ve watched videos & searched the manual, and I know how to view the lyrics data in the bottom panel (Command+8). However, I cannot figure out how to …
(4) make the lyrics for all stanzas consistently start left aligned at the beginning of each stanza, and at the beginning of each system;
(5) change the distance from the stanza # and the beginning of the first syllable (looks too big to me, and we need to conserve space);
(6) delete all manual adjustments I’ve made to lyrics and start over.

Two issues visible in the screenshot below:
(7) Why does the stanza # not align with the stanza’s lyrics?
(8) Are the syllables misaligned, i.e., no where near their notes (a) because I input them incorrectly (maybe on the wrong notes), or (b) because of my messed up manual adjustments, or (c) for some other reason?


22.01 Make Me a Blessing_lyrics_issues.dorico (1.3 MB)

It’s because the lyrics are not at the same rhythmic position.

Click the first lyrics and press Shift+N you’ll see the caret activates at the second rhythmic position. If you move the lyric back one position then it will work as expected.

(The same goes for a lot of your lyrics)

1 Like

Hi Eric, what @DanielMuzMurray said (which I was just about to type). I think it would be easiest to delete them and re-enter, unfortunately. This hymn is a bear.

Your verse numbers are a different font. Paragraph Styles–Lyrics (Verse Numbers)

BTW, Crimson Pro looks sooooo good. I love it.

Crimson Pro’s hyphen is like that. Here’s a version with a straight hyphen, which you can install in its place. (47.5 KB)


Eric, your lyrics are not anchored to the notes, how did you enter them?

Thank you, @DanielMuzMurray & @dan_kreider. With that information and that font, I’ll see if I can get things to look the way I want them to.

@k_b, I inputted the lyrics by selecting the first note, pressing Shift+L and pasting in lyrics I had in this format:

Pil-nas pa-sau-lis var-gų ir skriau-dos, daug gi žmo-nių pri-slėg-tų. Nešk jiems į šir-dį sau-lė-tos vil-ties, vesk iš tam-sos, kur švie-su.

Jiems a-pie Jė-zų tu drą-siai pra-nešk, kad Jis at-lei-džia kal-tes.
Jei at-gai-laus ir vien Jė-zum ti-kės, Jis juos iš-gel-bės iš-ties.

Duok do-va-nai, kaip ir Jis da-vė tau, mei-lę pa-ro-dyk ki-tiems. Iš-ti-ki-mai Jam tar-nauk, ne-pa-ilsk, Jė-zų pa-ro-dyk vi-siems.

Duok man tar-nau-ti, kaip tar-na-vai Tu, tad ir ki-ti pa-lai-mų gaus.
Duok man tar-nau-ti, O Jė-zau, pra-šau.
O Jė-zau, pra-šau aš
Duok dėl Ta-vęs man tar-nau-ti to-liau.

That is why it is so strange to me as to why the lyrics are not in the correct rhythmic positions. I’ve inserted the lyrics into around 200 hymns already, and I’ve never had this happen (that I know of). The only thing I can think of is that @dan_kreider did transpose the score from C to A major after I inputted the lyrics, but that should not do that…

Also, if you notice in this screenshot, the hyphens are different for lyrics in different voices. Why is that?

I figured it out: the lower lyrics were marked as “Is translation”, and the Library > Paragraph Styles > Lyrics (Translation) style was still set to Minion Pro rather than taking its characteristics from the Default Text style. Fixed that one.

That might have been me.

Attached is the current .dorico file.

I have now re-assigned the lyrics and I think they are in their proper places (without any more manual tweaking; I assume the old lyric shifts I did are still here). Here’s what I see:

(1) What do I need to change so that the first syllable of each stanza will properly align at the left “margin”? I drew in that red vertical line to show the variation.
(2) I think I saw somewhere a place to change the space between the stanza # and the beginning of the first syllable, but now I can’t find it. Where is that setting?
EDIT: (3) Is there a way to delete all manual moving of lyrics in a file / flow?

22.01 Make Me a Blessing_lyrics_issues2.dorico (1.3 MB)

  1. Engraving Options–Lyrics. I changed those settings for you.
  2. You shouldn’t need to do that, but it’s in the same place.
  3. Select them all, and in Engrave mode, open the bottom properties panel and un-toggle the Offset property. (Edit: also, remove all Note Spacing in the Engrave menu)
    22.01 Make Me a Blessing_lyrics_issues2.dorico (1.3 MB)

I did the first system for you. This is probably the most difficult hymn I know of to space properly.

1 Like

Thanks, Dan!