M-Audio Keystation Mini 32 no sound with Cubase

I´ve got an old Cubase LE 4 that I got years ago and had it in iMac back then, but then after iMac for years with a Windows computer I occassionally used some other programs, but haven´t really liked any of them as much as I used to like the old LE 4 (and I haven´t cared to buy a newer version of Cubase). I recently dug out the installation disk for the LE 4 and ran it on my Windows 7 (32-bit), just out of curiosity how well it would still work. And it works fine recording guitars through a Zoom effect pedal device just like always. But then I tried to hook up M-Audio Keystation Mini 32 and it gives no sound. It does receive something in the audio bars as I hit the keys, but just doesn´t give any sound. I got the ASIO4ALL driver, and even installed some M-Audio M-Track ASIO driver as well, but that didn´t give me anything either. I have basically tried everything that the Cubase manual has to offer and have searched through the internet for this problem. Meanwhile I have Ableton Live 9 Lite in which my keystation works just the way as supposed to. I´d hate to switch to Ableton for stuffs I do on home computer, ´cos that seems to be such a pain in the ass to work with, it´s so different and seems to take so much time to learn how to use it and I just hate it. I wonder if this same problem would occur with newer versions of Cubase…

If you have any ideas why Cubase is not giving any sound, please let me know!

So, it sounds like Cubase is receiving the MIdI from the keyboard, but are you routing that MIDI to an instrument in Cubase to produce some sound? Create an Instrument Track and select the keyboard as the MIDI input source.


It doesn´t give sound on an Instrument Track either, although does detect the keyboard and receives sound, just doesn´t give anything out… It seems very weird.

Only thing I can suggest is to post some screen shots of the routing, etc.

OK, I finally got it working! Quite frankly, I´m not even sure what I did that differently. I took time to read about the VST Instruments and Instrument Tracks in the manual again, hoping maybe I had just missed something there before. Still, when I first added an instrument track and chose HALionOne sound there, even tried editing it as if it was going to give me any sound… it still didn´t. Then I simply followed the manual and tried to find a SoundFrame button to open some “Load Preset…” dialog. Well, I added a new instrument track, chose a HALionOne sound like before, tried to look for that button and all of a sudden it just gave me sound. I tried on the previous instrument track, and it still didn´t. Nothing seemed to be that different with it. All the MIDI inputs and HALionOnes are exactly the same. It´s weird, but doesn´t matter now that it works. And it gives me sound to new instrument tracks I add, so it wasn´t just a one time thing that it worked. Hopefully I don´t lose these settings and have to go through these “finding sound” phases again. :smiley: Although maybe then I would know where the problem was after all. Now I don´t much care, ´cause I´m just glad I got it working with my Cubase.

Thanks for taking your time to answer anyway! I appreciate it!