M4a import

I find I am unable to load M4a files into my WaveLab Elements 9 (32bit) installation, although this worked and is still working if I use Elements 8 (32 bit). I do have Quicktime player installed BTW.

Has this support been withdrawn in the new version?

WaveLab Elements 9 support aac in and out, in 32 and 64 bits. Prior wavelab uses aac import only, and in 32 bit only. This was through quicktime. Maybe your m4a file is not aac. Do you know its underlying format?

I don’t know that info exactly PG…

The files which do not load into Elements 9 and give an ‘unknown format’ error message, but which do load fine into Elements 8 were Apple loss less m4a files downloaded from here:

I just tested with the AAC and m4a examples from here:
and these load fine into Elements 9 (32 and 64 bit) …but strangely these do not load properly, at least via drag and drop, into Elements 8 (they load but have strange looking wave images and are mostly noise).

All of the above files from both sites play without problem using Quicktime and indeed Windows Media Player.

I am confused :confused:

After checking: the file you try to open has the ALAC format (Apple Lossless).
WaveLab should be able to open them, but there is unfortunately a bug…
but there is a solution until a fix: just change the file extension to .caf, and WaveLab will be able to open them, if you use the 32 bit WaveLab version.

Thanks for the information and checking out the files PG. The help and workaround is much appreciated!

I just tried to open an m4a file a client sent me last night - it wouldn’t open. It plays fine in Windows Media Player, but in Wavelab, it just opens as an empty window.

When I get back to the studio, I’ll try renaming the file as you suggest above PG to see if it will open that way.

MediaInfo is an invaluable utility for finding out exactly what’s in such files.

Thanks for the tip - I just tried it on the M4a file that wouldn’t open in Wavelab. Here are the specs:

Format : MPEG-4
Format profile : Apple audio with iTunes info
Codec ID : M4A (M4A /mp42/isom)
File size : 27.3 MiB
Duration : 5 min
Overall bit rate mode : Variable
Overall bit rate : 676 kb/s

ID : 1
Format : ALAC
Codec ID : alac
Codec ID/Info : Apple Lossless Audio Codec
Duration : 5 min
Duration_LastFrame : -68 ms
Bit rate mode : Variable
Bit rate : 675 kb/s
Channel(s) : 2 channels
Sampling rate : 44.1 kHz
Bit depth : 16 bits
Stream size : 27.3 MiB (100%)
Language : English

Could you open it by renaming it to .alac ?