MAC: Disconnection from AUDIO MIDI SETUP

Hi there,
I just purchased the UR22C. I’m trying to get it working. If I restart the computer, and then plug in the interface, the device shows up in the audio midi setup and is selectable for both audio input and output.

If I try to start any pre-existing DAW I have, the device just disappears. Why?

I’ve tried Logic Pro and also Ableton Live.

I don’t have Cubase, and I’m not sure I want to learn, but something tells me this is not the issue.

I’ve got Mac OS 10.14. The firmware is up to date. The device works for both audio input/output on simple desktop applications (spotify).

What is going on here? Any help please??

Update: I’ve updated the Mac OS to Catalina, and problem solved. shrug

Hello, I have exactly the same problem.

I am using my UR22C together with my Windows Laptop and FL.

Now I bought an iMac Mini 2018 and want to use it together with FL and Logic Pro X.

At first, It worked fine, I could play back e.g. on youtube.

Also my Soundcard was detected by FL Studio on Mac.

When I then downloaded Logic X Pro, and tried afterwards to restart FL (after heaving restarted the system).

The sound card gets ‘lost’. I will have to remove it from the USB, then plug it in again.
It is recognised again, however, only if I do not open one of my 2 DAWs (see above). Then, the connection will be lost again.

I already have the newest Catalina and installed the drivers.

What can I do?
It doesn’t work on USB 2.0 mode either.

I have the same issue with my UR44C. Steinberg support is aware of the issue as I have spoken to several people. At this point it has been escalated to Germany. When you first boot up, it works fine. However, if you launch anything that uses it (Cubase, etc.), it disappears. SJ

Are you aware of this article?
https://helpcenter.steinberg.de/hc/en-us/articles/115001790330-macOS-Systemerweiterung-blockiert-Hinweis-bei-der-Installation-von-Hardware

A more general approach can be found in the article by Apple:
https://developer.apple.com/library/archive/technotes/tn2459/_index.html

It is important to know that the option to change the setting disappears 30 minutes into the session so a reboot might be needed to allow you to change the setting.

That didn’t fix it, but the newly released USB driver did! Thanks.

I am having exactly the same issues. Please can you provide a link to the new USB Driver ?

Many thanks.

Hi everyone,

I’m in the exact same situation. I made the acquisition of a UR22C a month ago and I’m still facing the same problem after reinstalling the drivers and all I could think of… Audio interface is detected when plugged, but as soon as I launch any DAW it just vanishes. I’m on a MacBook Pro from 2017 under Catalina 10.15.5.
If anyone that was able to solve this problem could help me, I would be grateful. Really starting to lose hope.

I’m having this exact same issue.

I have a video desctiption of my problem for you to see but you have disabled links in comments and you have also disabled new users form attaching videos as an attachments to the comments so that makes the video quite useless.

You can try to combine these lines to a complete URL to see the video if it works:

www.
loom
.com
/share
/204649afc09546099809687e627d7de7

I’m going to return the UR22C if this problem is not solved quickly. This is making the device useless.

My setup:
MacBook Pro (13-inch, 2020, Four Thunderbolt 3 ports)
MacOS Big Sur (11.1)
Yamaha Steinberg USB Driver V2.0.4
eLicencer version 6.12.6.1281

1 Like