[Mac] Key Command Transfer Issue?

Anybody with a Mac have trouble getting their key commands ported over with the N6 installation? I did, as none of my old settings came across with the installation.

Tried to import, and couldn’t get N6 to see the N5.5 key commands file–

Changed the file tag from .xml to .key, and they loaded right up.

Maybe this was discussed in previous threads? Maybe it’s the same on PC? Maybe it’s just me?

In any case, it was a big relief not to have to re-enter the whole shebang; hope this might be helpful to someone else somewhere.


I can’t import the key commands at all. The XML files are greyed out and I can’t select them. I’ve tried changing the file extensions to .key and I can select them, but then get an error message saying that they aren’t key command files. Same behaviour with files from N4, N5 & N5.5. Is there any other work around? I’m on OS 10.7.5.

UPDATE: As a work around, I copied the xml file from N5.5’s preferences/preset folder into N6’s and could then select it as a preset.

That sounds like a more elegant way of doing what I did.

I copied my stuff from N5.5 prefs, and copied file to the desktop (since you can’t get to home library prefs from the “open file” hierarchy in Mt. Lion… and then changed to “.key” for import.

Looks like just dragging from one place to another worked, as well… but I wonder if that got rid of any new presets specific to N6 (if that matters).


I’m on a PC and I copied the N4 KC preset into the N6 folder. But I still can’t get it to do anything because of the .xml suffix. I don’t know why It won’t let me access the string so that I can change it to .key!

If you’ve replaced the N6 KC prefs with your 5.5 .xml it should just read it… no need to make it a .key file, and no need to import it. Are you sure you’re dropping it into the right folder? Did you restart?


Well, maybe that’s the issue. I’m going from N4.3 to N6. I never used N5. I’ll try importing N4 KC’s into N5, save it there and then try the import again from N5 to N6. What a PITA this is. Thanks for your help!!

I ran into the same “brick wall.” I tried to import N4 into N5 and got the same response I got from N6, .xml is not a valid file (Grrrr)! Again, why on earth are these .xml files when the platform REQUIRES .key or .mac?!!?

Sorry it didn’t work for you. This is a strange little dead-end, and I don’t understand saving, exporting and transferring presets doesn’t work as described for many of us…

I can only infer that there is some system-based reason for your not being able to change the file tag-- I’m not good enough on Windows to help with that. But I’m really scratching my head on the .xml-not-working issue. And the .key file mystery.

Good luck to you. Would love to hear Steinberg respond to this issue.