Mac no sound after changing audio output

I have had some problems after changing to Apple Airpods, where output will stop.
Write mode would play each note and it would play on my internal MacBook speakers. Once I connected my Airpods, nothing would come out.
I checked Sys. Prefs>Sound, Dorico’s audio prefs, Play>Apply default playback template, mixer, loading sounds again etc. The main problem is, disconnecting the Airpods to use the internal speakers (or plugged in headphones) would no longer work either.
Wonderfully I can copy all and make an entirely new project and paste and everything will work again (but it means I have to fix barlines (to double) etc.)
It only has 2 players so is quite simple in playback needs.
Also sometimes play does not work (spacebar or clicking play button) which might be related to this.

Any ideas (Ulf?) Thanks.

That with the Airpods is a known issue. The problem is, Airpods are not only headphones but also a microphone and so there are two identically named devices. No matter which of the two you choose, always the first one gets picked, which is the microphone. So then Dorico doesn’t see any output ports and thus stays muted.
The workaround is to create a so called ‘aggregated device’ in the Audio MIDI Setup utility. In the left bottom corner of the Audio Devices window is a little plus sign. Click on that an choose Create Aggregate Device. Then select only the output port of your Airpod and rename the aggregated device to whatever you like.
If that’s done, start Dorico and go to Edit > Device Setup; your ‘new’ device shall appear in the list of ASIO drivers and be selectable.
That you can’t get your project to sound again even when switching back to internal speakers is another issue. Because of the Airpod issue the port mapping information does get lost and then it can’t get recovered anymore. We have a fix for this issue waiting to be released in the next Dorico update.
You could send me your project file and I can apply some “magic” in order to rectify it.

Thanks Ulf, for now I have a playing version but if I corrupt it again I will send it to you for your magic :slight_smile:
Thank you for the explanations. I understand what is happening each time finally. I forgot about aggregating but probably (wrongly) would have assumed it would not work also.

Ulf, I have noticed in Play mode, when I click the Piano on the left, there are many instances of the keyboard roll all with the same settings (ch 2, HAL etc.) with only two at the top having any notes or data on them. Would this have been caused by the audio corruption also? My flute has only the one listing.

No, this is intentional - they actually correspond to the voices in the instrument. In the next update we may merge all these views together, as the current behaviour isn’t all that useful.

Thanks Paul, I will ignore them then. Yes I was trying to work out what they were about and how it worked, then decided it might have been the corruption somehow.


  1. Install both Soundflower and Soundflowerbed:

  2. Let Dorico use Soundflower as audio output, then let Soundflowerbed to reroute the output audio stream to any physical DAC you want to use.

I’m pretty sure SoundFlowerBed is not compatible with High Sierra.

Soundflower works fine and is useful for Quicktime Player screen recordings with sound.

As an alternative to SoundFlowerBed, you can use a Multi-Output device to get the same functionality.

To do this, in Audio Midi Setup, create a multi-output device, and enable all devices that you want to use. (see Multi-output Device image)

In System preferences>Sound, enable "Show volume in menu bar (Sound preference image)

Use volume menu to select output device (Device selection image)

In Dorico (or any other app for that matter), select Multi-output device in Device setup.
Sound preference.png
Device selection.png
Multi-Output Device.jpg

I just used SoundflowerBed today on my MacBook Air running macOS 10.13 High Sierra and it works well. What are you nonsensing about?
Bear in mind: I have no time talking fake things here today. What I posted here today are all tested work. If not working on your side, you weren’t using the files downloaded through my provided URLs nor you forget to let the GakeKeeper allows Soundflower driver.

I tried soundflowerbed and it worked for a little while and then stopped working. I couldn’t open the menu without rebooting. Plus, Matt Ingalls GitHub site claims soundflowerbed is retired but being worked on elsewhere. Your link is for an old version. If it works for you then great but it seems unreliable to me.