Mac OS X 10.11.5 and Cubase 5 compatibility

My MacBook Pro is running OS X El Capitan 10.11.5 and I would like to use my old Cubase 5 program to do some recording. Does anyone know if they are compatible? Trying to install C5 but a window saying I need at least OS X 10.5 comes up, which doesn’t make sense. Any help is appreciated.

https://www.steinberg.net/forums/viewtopic.php?f=181&t=95573&sid=bfe770ab5d791ce0fba56b543b30bb64