MAC record dialog bug

Opening the record dialog from the selected track ‘Record at cursor’ produced a recorded clip placed at the correct place on the montage track.
If instead of pressing STOP to end recording you press discard, then reset cursor position, go back to the presently opened record dialog and start and stop recording… the clip does not appear in the selected track of the montage.
Each time I wish to do another take or change tracks it seems that I have to close and then re-open the record dialog, and then it inserts the clip properly again.
Whatever happened to that selection checkbox that was in the old dialog that allowed you to choose to put recording into selected track?
If there is a new method, teach me :question:

Let me a few days to check this.

OK, this will be solved in next version.

Just a reminder that this problem has not been fixed in 7.1

There are some nice features added in the layout. Thanks PG for your work.

I think this is fixed. But do you really press the record button from the Track’s menu?

From the track I select ‘Record at Cursor’, Click on Record, Click on Stop and a clip is inserted into the montage track.
However if I want to record again on this track after Record and Stop, a clip is opened in Wave Edit but is not placed on the montage track.
An example would be to choose a new track in Montage, Press spacebar to play, choose from track Record at Cursor and press Record from within the dialog window that opens… Press Stop and a clip is inserted on the track that is still playing.
Press Record again and then Stop and the resulting clip is not placed on the montage timeline but rather it opens up in Wave Editor.

I have tried this with Wavelab7.1 on both OSX and WinXP-pro with the same results.

OK, I can reproduce this scenario. Thanks.