[Mac]USB License error on Cubase SX3 yet Cubase 4 launches

I have purchased every FULL or PRO version of Cubase for the past 18 years. In fact, I still have the original Cubase SX 3 UPDATE/UPGRADE Box with the DVD and all included documentation which includes the activation codes.

Here’s my issue, I have updated and upgraded my Cubase, eLicenser & Syncrosoft eLicenser Control to the most current versions to date. I now have Cubase Pro 8.5, and I’m running the latest version of Syncrosoft eLicenser Control (v6.9.2.1184). These latest versions are installed on my MacPro running OS 10.9 Mavericks (yes, Cubase Pro 8.5 runs on Mavericks).

I have Cubase SX 3 installed on my iBook G4. However, when I try to use the same eLicenser USB dongle plugged in my iBook G4, Cubase SX3 won’t open up. It says that there are no valid licenses for the Application (please see attachment). The strange thing is that I have Cubase 4 installed on my iBook G4 as well and that opens just fine with the same USB dongle. So, what gives?
What do I need to do be able to open up Cubase SX3?
Do I need to use a separate USB dongle specifically for running Cubase SX3? If so, that’s fine. It’s only $27. But I just don’t want to waste the money if it’s not going to fix the problem. Or if there’s another solution using my current eLicenser USB dongle.

I don’t use any Apple products so I’m not sure what’s going on with your SX3.

Your screenshot looks weird in that it shows SX3.0 when you have 3.1

Must be an elicencer or Mac specific problem as I can run SX3 and newer versions fine on the same dongle using Win7/64 Ultimate.

I guess if no one else replies you should contact Steinberg support.

Thank you for your reply. I don’t think the error message is specific to the version number. I believe that it’s merely stating that it is referring to SX3 regardless of the update version.
Apple has made a lot of changes regarding their computers and OS over the last 10 years where they make it very difficult to utilize older versions of software on newer macs. Very frustrating in matters like these where using an older software is required.
I wish that Steinberg would create a software that would allow Mac users with the most current computers and OS to be able to convert the older pre-OSX Application sessions/projects.

I understand your frustration.

The first thing to look for would be to launch eLicenser Control Center and check that your license is displayed there.

The second thing to check is that the latest version of the eLicenser Control software is installed (if you simply ran the Cubase SX 3 installer, it would have installed a very old version of the eLicenser Control software that doesn’t understand yet what a “Cubase 8.5” license is supposed to be).

Thank you for your responses! I finally was able to fix the issue. As you mentioned, it had to do with the License Control software that needed to be updated. For some reason when I tried to update it before, it would tell either that the LCC could not be installed because a newer version was already installed on my computer… which wasn’t the case. Or when I tried to install later versions (past LCC v6) it would tell me that it wasn’t compatible with OS 10.5. The remedy was to uninstall the currently installed version (LCC v4.9). And then I installed LCC version v6.3 (which is the latest LCC sw that can be installed on my iBook G4 running OS 10.5). I ran the maintenance program in the LCC which completed without any issues. And when I opened Cubase SX3, Presto!!! IT WORKED!!! I just wanted to let you know what I had to do in case someone else might come up with this same issue in the future. Thanks again for your feedback and responses!