[Mac] Yosemite and installation probs.

Aloha Mac guys,

Just in case you did not catch this Steinberg announcement (and are planning on getting a new ax
with Yosemite pre-installed as an OS).

Seems there is an installation prob.

(probably more Apple ‘sandbox’ crap that Steiny now has to work-a-round).

In any event if you are planning on getting new stuff
and then installing Cubase and other Steinberg stuff , best beware and be safe.

BTW
a solution is provided. Yea!
{’-’}

Read on:
http://www.steinberg.net/en/newsandevents/news/newsdetail/article/official-letter-on-yosemite-update-2837.html

it’s not ‘sandbox’ crap just a wrong os version check in the installer.

=10.6 is the check but 10.10 (in fact 10.1) is lower than 10.6 so the installer fails and thinks you’re on osx 10.1 instead of 10.10

Cheers

Indeed, Apple’s not to blame here!

I was struggling to get 7.5.20 working on Yosemite. Now I have it working.

@Ed Doll : Do I have the permission to post the solution for this for other Cubase users & OSX ?

Vivo, not sure what you mean? We have a statement online which is linked at the topic start and that one includes a download link for the Steinberg Application Installation Tool to work with Yosemite.
What do you have in mind you want to post?

Hi,

Well the tool does not work for the 7.5.20 update (that you install AFTER the 7.5.0 Iso’s).

I did a repackage with pkgutil and got it working now. If people want I can post a very simple solution.

Sure, I don’t mind if that is a proper workaround for you. Thanks!

Ok here we go for installing Cubase 7.5.20 update on OSX Yosemite 10.10 (dp3 in my case, dp2 has problems with closing plugin windows with the red X button, so better update).

  1. Mount ‘Cubase 7.5.20 update.dmg’
  2. Drag/Copy Cubase 7.5.20 Update.pkg to your Desktop
  3. Open a terminal (from /Applications/Utilities) and type in:
cd ~/Desktop
pkgutil --expand "Cubase 7.5.20 Update.pkg" cubase752.unpkg
  1. Leave terminal open, now go into the cubase752.unpkg folder on your Desktop and rightclick the file Distribution and chose to open with TextEdit.
  2. Remove the following code from that Distribution file:
if(!(system.version.ProductVersion >= '10.6.0')) 
  {
    my.result.title = 'Wrong Mac OS X Version';
    my.result.message = 'You need at least Mac OS X 10.6.0 to install this software';
    my.result.type = 'Fatal';
    return false;
  }
  1. Save & Quit TextEdit and type in terminal:
pkgutil --flatten ~/Desktop/cubase752.unpkg ~/Desktop/Cubase752_Yosemite.pkg
  1. Done you have a working 7.5.20 Yosemite update for Cubase. (You can install it by double-clicking Cubase752_Yosemite.pkg on your desktop)

Happy sequencing!

Great info.

Love this place.
{’-’}

Thank you Vivo! repacking with the installer code edit worked for me! Cubase 7 is running in 64bit on my brand new Yosemite imac ::fingers crossed::

Will report back if any issues arise.

Steinberg!!
This took me five minutes and I don’t know what I am doing…
Why can’t you do this yourselves??

I tried to install Cubase 6 Artist and had the same problem. It thought my OS X 10.10.5 was lower than 10.6.
I began with Terminal as instructed, but after entering the first line (cd ~/Desktop pkgutil --expand “Cubase 7.5.20 Update.pkg” cubase752.unpkg), I got cold feet because this was Cubase 6.mpkg, not Cubase 7.5.20 Update.pkg, I did not have Text editor, and like Johnmarkpainter I did not have a clue what I was actually doing inside Terminal. I exited Terminal hoping that entering the first line of the instruction would do no harm. Turns out it did. When I try to open Cubase 6.mpkg, I get asked which program I want to use, and there is nothing inside Cubase I can choose, because Cubase 6.mpkg is supposed to start the process, and it has been deactivated, obviously. My question is: How can I undo the first line of the instruction in Terminal?

By the way, my OS is not working at the moment and I don’t know when it will, because I tried a different way of managing the problem, by simply changing the OS X number from 10.10 to 10.7. I was a really simple operation, but again I was a fool to mess with Terminal, because now I can’t run several programs including Terminal, because they are based on 10.10.
However, I suppose I should try to get support from Apple rather than Steinberg for this issue. I mention this anyway, because I think you could have made a small installation package to solve the initial problem, instead of making customers use Terminal and risk further complications.

Hi Vivo,
I have the same problem with my Wavelab LE 8.pkg
Can you please go through with me with Wavelab instead of Cubase?
Thanks