Macbook Pro with Retina trackpad issues

I searched through the forums and I’m not aware if this is a known issue. When I launch Cubase 6.5.1 on my Macbook Pro Retina the mouse clicks seem to be offset in Cubase. The menu bar at the top works as expected but GUI elements like the Project Assistant and even adding tracks in the project view just don’t work at all. At least the clicks don’t register in the correct places. Has anyone else experienced this issue and is there a known fix? I have tried changing the resolution because I suspected there is an issue with the way the MBPR is rendering the pixels (doubled then scaled down). Thanks in advance!

[Quick Update #1]: I tried with a magic mouse and no change. Also, Cubase is the only application that is having this problem at the moment.

Aloha s,

1st congrats on getting your new 'puter.

As respect to the Retina Display IMHO most developers will adjust their
apps in the near future to best optimize this new hardware.

Guess Steiny also had to wait to get their hands on a RD Mac.
Lets give them a lil time for new up-dates/grades.

Also there will probably be some radical GUI changes when it comes
to OS10.8 (Mountain Lion) and Windows 8 (Metro).

{’-’}

Having the same problem here on my MBP Retina. :frowning:
Was hoping to be able to use the awesome screen estate of the Retina display but instead Cubase 6.5.1 isn’t usable at all on that machine. :frowning: :frowning: :frowning:

I really hope that Steinberg will come up with a patch for this problem very soon …

Any official statement you wanna make, Steinberg guys?

by the way: that’s not only happening with the “More Space” display option but also with the “Best (Retina)” setting.
:frowning:

Ableton Live doesn’t have such a problem, btw. And they didn’t have to release any patches for the Retina MBP. Being a developer myself I wonder how Steinberg is coding here … :neutral_face:

I too am having the same issues.

I selected the reduced resolution mode and it remedied everything, but I want an update so I do not need this workaround.

Isn’t it the most beautiful computer in history?

Hi there,

There is already a knowledge base article about this problem:
https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/using-a-macbook-pro-retina-display-with-steinberg-software/kb_back/2020.html

Bah, it’s a bit disappointing to see such a beautiful screen then Cubase has to run in low resolution mode. Still, it works and that’s the main thing! (See knowledge base article).