Mackie Control Universal (MCU) compatibility with Cubase 12 & macOS Monterey

Hi all! I have an old Mackie Control Universal (a MIDI fader controller, firmware 2.1.2), bought around 2008, NOT the Pro version. After not having used it in quite a while, I realized that it no longer works with my current, fully updated system (MacOS 12.4, Cubase 12, MacBook Pro 2021): Its LED display no longer reliably displays the values of the Cubase mixer as it should (only sometimes), and it frequently (but not always) appears to be in a messed-up state where it misinterprets or ignores my button presses.

Does anybody know whether this is actually still supposed to work with my new software and hardware, or is this beauty sadly incompatible and therefore ready for the trash?

Hi,

Do you use the old Mackie Control device from the Studio > Studio Setup, or do you use the new MIDI Remote?

In general, it should be compatible. Do you have the very old MIDI version? What MIDI device do you use to transfer the MIDI data (MIDI <> USB)?

Thanks for your reply, Martin. Thankfully, the problem has now been resolved – your encouragement that the device should indeed still work kept me going, and you indeed pointed me into the right direction.

I do have the very old MIDI version of the Mackie MCU (i.e., counted via MIDI cables, my Mackie does not have a USB port), and it appears that my MIDI<>USB-C adapter cable (https://www.amazon.com/gp/product/B09KZ3X59K) was to blame.

I now switched to using the MIDI inputs of my new Focusrite 4i4 audio interface, and the problems disappeared immediately. I can imagine that that faulty adapter couldn’t handle the data that Cubase sends to the MCU to initialize it, which is supposed to position the MCU’s sliders to the right position and initializes its display; maybe it is too much MIDI too fast…

BIG kudos for Steinberg to still support my Mackie Control Universal, even though it is about 15 years old!!!

Cheers, Matthias


To other people coming here looking for tips for their Mackie MCU – this is how you set it up in Cubase 12:

(1) Go to Studio → Studio Setup… → +Add Device → Mackie Control
(2) Then in Studio → Studio Setup → Mackie Control → MIDI Input / Output, select your MIDI interface connecting to your Mackie MCU, then click on “Reset”. Your Mackie’s sliders and display should now automatically move/adjust to the position given by your Cubase project, if you have it open.
(3) In Studio → Studio Setup → MIDI Port Setup, find that same MIDI interface in the list and unselect “In ‘All MIDI Inputs’”. This will prevent the Mackie’s MIDI signals to Cubase from being recorded when you record MIDI in a MIDI track whose inputs are set to “All MIDI”.
(4) Close the Studio Setup with “OK”
(5) In Studio → More Options → Mackie Control, which decides which of the MCU’s buttons does what, I selected “Compatibility”. My Mackie MCU is NOT the Pro version (it is really old), so Compatibility mode seemed to do exactly what is printed on my Mackie. For the Pro you may want to choose the other option (“Cubase”); try for yourself.