mackie mcu pro and extender.. also maschine

Since buying MCU pro and extender I cannot get them both to work. I can use MCU pro by itself but not the extender with it. I select mackie control then add MCU pro then add another mackie control for the extender. When I create instrument tracks either both faders move on the MCU pro and the extender they seem to be fighting each other. How can I fixed this?

My os is win 7 64 bit 32gb of ram… Cubase 8.5.15

Also lastly adding maschine plugin but getting first part is my larger concern because I believe I have the fix for maschine.



Make sure, the MCU MIDI In/Out Ports are used for the MCU Pro, but MCU 2 In/Out ports are used for the extended, please.

I have MCU pro connected USB to my PC and extender midi to the first port on the MCU pro?


Yes, this is correct. Then the settings of MIDI ports should be, as I mentioned, in Cubase.

The first set of ports on the MCU pro are port 2?

I think so. The first Port, which is close to the USB connector.

In the Device Manager the first set of Ports for the Master Unit are called “MCU Pro USB Vxx”.

Then the next set - the hardware ones on the MCU Master for the first extender - are called “MIDI in2 (MCU Pro USB Vxx)”, then 3 and 4. MIDIx out, of course, for the outputs.


Hmm everytime I setup mackie control it reconize both but it always defaults to MCU pro first then the extender… it works once then when I save a template it does not work?


What do you mean by “save a template”, please? Do you mean the Project template? This is not project related. This is a system settings.

By saving the project as default and using it everytime I start making a beat? Is there another way?

I just wasn’t sure, what do you mean exactly.

As I said, this is not project related setup. So it should stays with Cubase.

Could you send a screenshot of these two Mackie Control Devices, when does it work, and after opening the template? I would like to see, what is different.

By saving the project as default and using it everytime I start making a beat? Is there another way?