Mackie MCU Pro Operational Instability

Folks, It appears I am the only one having this problem, but just in case I am sharing the info anyway.

Let me first describe the problem.

When I start a project with the MCUPro connected, it does all the right things, sets the position display, positions the faders, etc. In fact, most of the time I can start, stop, and rewind, etc., however after a seemingly random amount of time Cubase (7.5.20) stops seeing command from the surface. You can tell this not only because it doesn’t work but the transport panel doesn’t show midi activity from the surface at the time of the failure. At first I though it might be a USB problem, but if I start the project song using the mouse the MCU Pro Time Display follows the transport pane as expected. This implies that data is flowing one direction (down to the control surface) and not the other (up to the application.)

I have made and placed a 3 min video on YouTube to demonstrate what I am talking about. If anyone has a clue I would be appreciative of feedback.

Both Steinberg and Mackie have not been very helpful other than to say they haven’t see the problem before and I am stuck without enough hard info to place it—this is a tough one.

If you need the specifics on my system let me know, but I didn’t want to upload all my system that data here unless someone really wants to see it.

What I will say is I have the latest MCU Pro Firmware, latest USB drivers for Win7, all power savings off, no hyperthreading, and the latest Cubase software.

All the best, Ted


Ok, I now believe it is the Mackie Control Surface. I simply couldn’t find an “absolute” way to prove this, and still can’t, but the circumstantial evidence points to the surface. Case in point, it will not operate properly using the port 2 midi I/O. Interestingly data flows to the surface (moving faders and operating the counter) but “NO” data flows up the midi connection—verified by the midi light on the Midex8–and yes, I tested the same connection with an old Motormix–it was fine. Tried another DAW among other things…same thing. Case closed. I got a bad Mackie MCU Pro out of the box.

Best, Ted

I’m having similar problems and have been since I updated to Cubase 7.5.10 (up to v7.5.20 with these symptoms). i.e. MCU 8 would stop controlling Cubase at some point in time. No error messages, no PC lock but in my case, sometimes my MCU 8 would loose Track/Channel information in the MCU’s LED bar and showed no Cubase information. Like Ted’s issue, MCU 8 does continue to show Time/Tempo information if I use Cubase Transport Controls. Sometimes, if the LED bar did NOT loose Track info, the MCU 8 would resume working after some elapsed time.

I updated to Cubase 7.5.30 and now, the MCU won’t work in Cubase. Neither 64-Bit or 32-Bit versions. It won’t work not even at the beginning. It does continue to show Time/Tempo information but does not show any Track/Channel data.

I currently have a trouble ticket in for another issue that surfaced after I updated (LoopMash Fx has a Blank Quantize Screen). I do think the MCU 8 issue is Cubase but- don’t know if the LoopMash issue is related. Love to hear some ideas on fixing this. :confused:

OK. I’ve just verified the problem IS Cubase 7.5.30 (7.5.20, 7.5.10 …). I connected my Mackie MCU 8 to another PC .

Using PowerTracks Pro 2012 (AKA PTW. It’s not compatible to the MCU 8 so, the Transport features & Track Led aren’t supposed to work. But the MIDI Pass-thru is compatible if the MCU is working). Both of my MIDI Keyboard Controllers (MCU 8 is a Hub function for these 2 KBs) are working as supposed to.

In my Cubase 7.5.30 DAW, my MIDI signals are not passing through to Cubase- dead, nothing.

More testing on a PC running Cubase 5.1.1., the MCU 8 runs flawlessly. LED panel, Track data, Time data, Transport Controls- all working flawlessly. This is definitely a Cubase issue … v7.5.10-30 for sure and maybe others.

I installed Cubase 5.5 64-Bit on my Cubase 7.5.30 DAW and the MCU 8 works on the v5.5! This is looking definitely like v7.5.10-30 updates did not work well on my PC.

Problem solved! I uninstalled Cubase LE AI 7 Elements from my PC and the MCU 8 is functioning perfectly now in Cubase 7.30!!!

So, remove all the older versions of cubase and things just work ?

In my case, that’s all that I did. Yep, Cubase is now working with my Mackie MCU Pro 8! :slight_smile:

What the HECK?!! I updated my Gigabyte Video Card Driver. It fixed a problem with LoopMash Fx but now, Mackie won’t work any version of Cubase on my Windows 7 64-Bit PC. Prior to my upgrade, it was working in v5.5 & v7.5.30 AFTER I had uninstalled Cubase LE Elements. I’m dumbfounded! >:(

Update. I found the new culprit. I had a bad USB cable connected to my MCU8. The cable registered ‘connected’ by my PC but may have been shorting signals needed for proper functioning. My MCU is now working fine on either USB2.0 OR 3.0. :slight_smile:


Though it been quite some time since my last post, I did want to followup. I am very frustrated about this and I don’t have an easy way to figure out where the problem is–short of having a hardware based USB analyzer in hand. However, since my last post I have:

  1. Worked with Mackie’s customer service and the determine the surface looked like the problem.
  2. I sent it to who they recommended to fix it, he proclaimed the unit ok. (I didn’t get my unit back for months-had to write Mackie for help to get it back.)
  3. Got it back, still a problem.
  4. Bought a new motherboard and installed windows 8.1, thinking if this is OS or Hardware related, this SHOULD solve it. NO GO.
  5. Now trying to figure out where I can get another Mackie to test with or find someone who has Cubase that I can test it on.

I am of course running 7.5.30.

Since I am futzing around trying to save my $1200 investment (now much more due to my time and shipping costs, etc, I did want to point one thing out to Steinberg–

If you inadvertently lose connection to the Mackie, due to lost power or lost USB connectivity, you must reboot Cubase to regain connection. I have tried using the Device setup window to reconnect the control surface, but it locks up Cubase. Perhaps there is an unavoidable technical issue that creates this situation, however it is inelegant at best. The argument will be, you should never lose connectivity in a professional environment, however, a bug is a bug. :wink:

Best, Ted Sopher

Me too. It appears my final issue was my USB cable. Also, Previously, I had my MCU8 serviced for a LED card and the repairman connected the new board incorrectly causing my MCU8 USB to malfunction. (not related to my cable problem) What I’ve learned is there may be multiple issues at hand and each needs to be solved before moving onto another.

I may be wrong but, I believe this is by design. IMO, it protects from corrupting Project files and/or Device drivers for your Audio Interface, MIDI Controllers, etc. I remember reading in my Cubase v5.5 Owner’s Manual that if Cubase should, lock, loose connection to the PC peripherals etc., that it was " … best to reboot the computer …".

I’m guessing that remains true in version 7.5x. I read in my new Steinberg UR824 Docs, not to connect/disconnect the UR824 while it is being accessed by a program. I believe to avoid corrupting the UR824 software, Cubase or other drivers.

While USB technology will allow Windows to reconnect to such instances, Windows is the OS that merely ‘connects’ to peripherals (e.g. Adapters, Controllers, etc). Cubase is the program that actually talks to these connections (Firmware/drivers). :nerd:

I have exactly the same problem with my mackie controler and cubase 7 as Ted discribed. Ted did you find out what the problem was? I have tried everything, i cant solve it.

/ johan