Mackie Protocol issue with controllers (nanokontrol2+others)

Short Version:

  1. Is there any way I can prevent Mackie Control protocol from sending “note on” and other midi messages apart from the “control” (transport/faders/pan pots etc.) ones when I use it with my Nanokontrol2 in Cubase 5? Disabling “Include in All MIDI Inputs” checkbox for Nanokontrol2 can’t be a valid, handy option (see detailed version). Some workaround? A custom xml maybe?
  2. Going the add nanokontrol2 as a “generic remote control” route it seems that Cubase is unable to send midi data to the nanokontrol2 which results in wrong led positions. Am I doing something wrong? Also, how can I make it so when I press the “stop” button in the nanokontrol2 the “play” button led goes off (as it happens in the Mackie mode/ as it should be).

Detailed Version:
So, I am using the Mackie Control protocol with my Korg’s Nanokontrol 2 in Cubase 5 in order to control the transport buttons and mixer as it is officially suggested.
Everything works great except the fact that when in “Mackie mode”, apart from the control messages sent when I press a transport button, I also get “note on” and other controller messages resulting in notes getting played or vst synths getting detuned If a midi track is selected which causes a highly undesirable mess.

I guess this is the way the Mackie Control protocol works in general? This makes no sense but it seems this is the case since Nanokontrol2 manual advices to clear the “Include in All MIDI Inputs” check box for Nanokontrol2 within Cubase options.
This solves the issue but as you can imagine it creates another:
When you change into nanokontrol’s “midi cc” mode in order to control a plugin you have to either enable “include in all midi inputs” again or change the midi input for the midi track in question to nanokontrol exclusively. But that means it will not be able to pick notes from my midi keyboard then. And to make things worse, it means that after you’re done and you want to turn into “daw/Mackie mode” again you have to change settings AGAIN.
Naturally, doing that every 2 mins can’t be an option so there must be an alternative I am missing. I mean, how other people who work with nanokontrol2/other controllers using Mackie control protocol cope with this?

All I can think of as possible solutions are:

  1. A modified Mackie Control xml which somehow keeps the control messages but excludes the others (“note on” etc.). I don’t know if this is even possible.
  2. A nanokontrol2 template for Cubase that acts like the Mackie Control minus its issues. I see custom scripts for other DAWs which actually improve nano’s functionality but none for Cubase so if anyone has something, please do share.
  3. Ditching Mackie Control completely and add nanokontrol2 as a “generic remote control” which simply doesn’t work as good as the Mackie Control and seems to have a problem of its own. It then seems that Cubase loses the ability to send midi messages back to nanokontrol2 which is probably why changes in solo/mute and transport buttons in Cubase don’t reflect into those in the nanokontrol2 leds. Also the “play” button led stays on even after the “stop” button gets pressed which is problematic. Both issues don’t occur while in Mackie mode, maybe some other nanokontrol user can shed some light on this one. Thanks a lot!