MacOS Catalina: Keyboard Shortcuts bound to regular numbers will trigger by Numpad

Nuendo 11.0.40, mac OS Catalina.

Steps to reproduce:

  1. Bind something to a regular number (0 - 9)
  2. Make sure the corresponding number on the Numpad is unbound, and close the Keyboard Shortcuts dialogue.
  3. Press the corresponding number on the Numpad.
  4. Observe that it will trigger the shortcut bound to the regular number.

Expected behaviour: Since Numpad numbers has their own shortcuts, expected behaviour would be that it will not trigger a shortcut bound to a regular number.

Actual Behaviour: As listed above.

The only conclusion would to treat this as a bug since it simply makes no sense to have this logic.

Temporary Workaround: Bind an empty “dummy macro” to the corresponding NumPad key.

Interesting. Here, on Windows it works correctly, maybe Mac only?

What happens when you type regular keyboard numbers compared to numkeys as below?


Is that a prerequisite for reproduction of this? What happens if the numpad keys are bound to other functions?

@MattiasNYC If the NumPad-number is bound to function, it will trigger that function.

If it’s NOT bound to any function, it will instead trigger the “non-numpad” Number’s function.

Therefore, the current workaround to create a “dummy macro” doing nothing will be treated as a replacement.

I will give an example, follow this procedure (which was where I discovered it):

  1. Assign “Workspace 3” to regular number 3.
  2. Make sure Num3 is not assigned to anything.
  3. Inside Keyboard Shortcuts, it will look like Num3 is not assigned to anything when pressing it.
  4. Close Keyboard Shortcuts and press Num3.
  5. For me, this will trigger Workspace 3.
1 Like

Also adding an interesting difference:

Pressing Num3 will cause the “Workspace”-menu to briefly flash. This doesn’t happen when using regular 3 to trigger the function.

I would assume this is specific for Mac if you can’t reproduce it.

I’m on Mojave-- and that’s not happening here. My numkeys and keyboard numbers are working as expected both as defaults and as assigned.

I’m also not getting the “num 3” workspace menu flash.

Maybe just a Catalina issue? Or a “replace prefs” situation?


I have the same behaviour on both my Catalina computers, so maybe something there. I’ve double checked the System Keyboard preferences, but I can’t see anything odd.

Have you tested to see what cubase is receiving from the OS keyboard using this, below?

It behaves the same way as your screenshot.

Pressing Key 3 shows only “3”. Pressing 3 on the numpad show “Num 3”.

So it appears in the Keyboard Shortcuts dialogue as everything is normal. But the software will still trigger the shortcut assigned to “normal 3” when pressing Num 3 when the Keyboard Shortcuts dialogue is closed.

EDIT: Also tried switching to a different layout (US International) than my language (Swedish), still same behaviour.

EDIT 2: In case someone else has this issue: The workaround mentioned also requires the actual “dummy macro” to contain something, so I created an empty logical project preset for the dummy to trigger. This blocks the bindings on the Numpad keys.