MacOS Catalina & UR242 - Dissappearing

I’m been using my UR242 on my mac with both GarageBand and Logic Prox until now.
Tried today using current OS Catalina 10.15.2 and my Steinberg UR242 disappeared from system preferences upon opening both programs.
I have updated, deleted, reinstalled, updated, emailed, searched and tried many options but simply following happens every time
open mac pro
Upon restart or new start - I look in system preferences for audio devices and UR-242 is listed
I Open either GarageBand or Logic pro and they are no longer listed both in system preferences or in either program for input or output.
has anyone and solutions?

I’ve got the same issue too. New Mac Book Pro 13 2020 with stock macOS Catalina installed and today’s connection fail.
The DSPMIXFX detects and can interact with my UR242 but since I stated it it disappearing from system audio devices and when I try to start Garage Band too. Do you have any solutions?

Dear Steinberg/Yamaha! Why you ignoring our messages about this issue?

Hi I am having the same issue with Catelina 10.15.6 and a MacBook Pro.

After installing from the following link

I can see the UR242 showing up in the audio devices when running Applications\Utilities\Audio MIDI Setup.

But as soon as I start either Garageband or DspMixFX UR242, the driver disappeared.

Steinberg team, is there a fix? Thanks.

Hi, same problem here. But with UR22 MKII. I have Macbook Pro 2020 and found my hardware in preference after restart. When I start my DAW (Cubase 10 Pro, Logic Pro X or Garage band) my UR22 disappear from preferences and ‘cannot be found’ in DAW. Could you please give us an answer?

I don’t really think so, that the problem is in the computers.

Thank you.

I have the same problem, have been using the UR242 on a MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports) for more than 3 years, lately running Garageband 10.3.5 over MacOS Catalina 10.15.4. The Steinberg input/output options just disappear from the System Preferences and System information once Garageband is loaded. I realized this is an old issue but I started to experience just on 9/20/2020. Could you please respond with a fix?


I have the same issue and it does not seem Steinberg is paying any attention to this.

No one figured this out? Both my UR22mkII and UR22C disappear when I launch Cubase installed on Catalina. Both interfaces worked fine on Mojave.

Just found this on another thread and it worked for me so far. So in typical Steinberg fashion, it was an issue in 10.5 that carried over, unfixed to 11. Sheesh. This is their software AND hardware.

I moved the Steinberg MIDI driver from the Library>Audio>Midi Drivers to the desktop for safekeeping and then rebooted.