MacOS compatibility issue


I’ve built a VST3 plugin using VST SDK 3.7.5 with minimum deployment target set to 10.13.

It’s works in my Virtual machine Big Sur 11.6.3 (where it is built) and in two other macbooks with Monterey (12.3.1 & 12.5). Today I received emails from two users with Catalina/Mojave saying that the plugin isn’t recognized at all (they tried Cubase 11, 12 and Reaper).

The plugin bundle is signed using a “Developer ID”. It’s also notarized with Hardened runtime enabled but with Disable Library Validation enabled too. I’ve also tried with default signing and it still doesn’t work for them.

Does anyone know what’s happening?


Ok I found the issue. I used the validator and it failed to load with the following error:

Library not loaded: /System/Library/Frameworks/UniformTypeIdentifiers.framework

It found out that UniformTypeIdentifiers (macOS 11.0+) was linked somehow. Instead of manually removing it, I decided to verify if the macOS deployment target was set properly (via [SMTG] output). It turned out it wasn’t, although Xcode general info page said “10.12”!

So I added the following line before project() and now it’s loading just fine:

1 Like