[macOS] Dorico insists on using MacBook speakers, even though the OS is using another output device


Congratulations on the Dorico 4 release, I really appreciate the great work!

I noticed an issue where Dorico 4 insists on using the built-in speakers of my MacBook Pro, even when macOS is using another device for output:

As can be seen from the screenshot above,

  • The OS is using “LG HDR 4K” as the audio output device, shown both in System Preferences and the Control Center
  • In Dorico Preferences > Play > Audio Device Setup, “Built-in Audio” is chosen
  • In Dorico Preferences > Play > Audio Device Setup > Device Control Panel…, “Automatically Configure Devices” is enabled, as instructed in this Dorico 3.5 help article
  • In Dorico Preferences > Play > Audio Device Setup > Device Control Panel…, the output device Dorico is using is “MacBook Pro Speakers 48000 Hz”, even though it should be “LG HDR 4K”

I am 80% confident that this issue was fixed some time between the release of Dorico 3 and Dorico 4. Anyway, what should I do to make Dorico automatically use the current audio output device macOS is using? Thank you in advance.

My experience with both 3.5 and 4.0 on Mac is that Dorico remembers what it was playing through the last time it ran, regardless of subsequent changes to the output in the System setup. For me that’s a matter of laptop speakers vs. headphones, so just plugging and unplugging headphones (or vice-versa) resets it, without my having to restart Dorico. I don’t know whether it might be more complicated with other external devices.

Hi Mark, thank you for the reply!

That could be the case, and it could also explain why I vaguely remember this issue being “fixed” some time ago for me. The problem is, the plug-and-unplug method doesn’t seem to work for me.

When at my desk, I dock my laptop and use it as my desktop computer. The only cable connected directly to the laptop is a USB-C hub, which I regularly plug in and out. Every time I plug the hub back in, macOS automatically switches from the built-in speaker to the hub for audio output, but Dorico still uses the built-in speakers.

Just to clarify, is this while Dorico is running, or before you launch it?

Hi, I’ve just reconfirmed this with one of our engineers.
The option “Automatically Configure Devices” is only for the built-in audio devices, namely the built-in speaker and the headphone device.
When it comes to other external devices that option does not work.

So Dorico will not automatically follow whatever device you have chosen as system output, you have to go to ‘Edit > Device Setup’ and tell where it shall play out to.

Sorry if this is not the way you expect it to be.

1 Like

I should have made that clearer, Dorico is not running when I plug the hub back in. But alas, Ulf already replied that my “issue” is expected behavior. :smiley:

Ah, okay, I learned something. So that’s Preferences > Play > (scroll all the way to the bottom) Audio Device > Audio Device Setup > Device Control Panel > Input/Output Configuration > (and finally) Automatically Configure Devices > Output ✓ (not checked by default). I had not found that yet in the 6 months I’ve been using Dorico.
Thanks, Ulf.

Hi Ulf,

Thank you for the help!

That perfectly explains my experience.

If anyone is interested, here’s what happened to my setup: I used to plug in an older USB-C hub and a 3.5 mm audio jack directly into my laptop when using it as a deaktop computer. Late in 2021, I bought a new USB-C hub and now plug the audio jack in the new hub instead of directly in the laptop. I mistakenly thought this is a new issue, when in reality it’s caused by a change in my hardware setup.

You can more easily get there via Edit > Device Setup

Aha! Thanks again!