macOS Mojave and Catalina: eLicenser Control error

Hi,

I’m having an eLicenser error in Catalina described in Steinberg support here:
https://helpcenter.steinberg.de/hc/en-us/articles/360010488240-macOS-Mojave-and-Catalina-eLicenser-Control-error

My eLicenser Control Center mac application is updated to the latest one (v 6.11.10.2263). When I try to open the Control Center app, then it freezes for a while and display the error report message shown in the upper link.

The support link does not provide any info how to fix the problem. In my case I cannot run Cubase Pro 10.5 on my new mac.
The eLicenser I use is the new model (small one) and works perfectly on the other mac High Sierra and on my Windows 10 machine.

Any clues?

Hi,

The linked issue is about

When using eLicenser protected products (plug-ins, VST Instruments) in 3rd party host applications

What is not your case, if you use Cubase.

Maybe try this one.

Thanks for your reply!
The problem is that the Control Center application stacks (cannot read and show the licenses) and displays the message I posted in the original post link. The problem is I cannot even run Maintenance in the Control Center in case it does not work.
Respectively I cannot run Cubase 10.5 or VEP7 etc.

Hi,

The article I sent link to, doesn’t ask to start eLCC. Please follow the instructions.

Similar here: in particular, Logic will not load any of the Steinberg Absolute 4 AU plugs (and this of course is the only plugin format that Logic will use). As for the rest of the list in the link, all fine as VST2, VST3 & AAX. It is the AU plugs which will not run.

You are right, but if eLCC does not run (the bug I describe) then nothing will work - am I correct?
I got the same error message when I run Cubase 10.5 or VEP7. I know all of the article you provided and all similar related mac tips.
Thanks for your time!

Hi,

You don’t have to start eLCC application or Cubase or VEP7 to fix it. Just start macOS System Preferences and follow the instructions. Once you are at the end of the process, start eLCC/Cubase/VEP application, please. Hopefully it will work.

Things to try:

  1. Run the e licenser installer app and run the UNINSTALL from there
  2. Go to the preferences files, HD/User/Library/Preferences and look for com.Syncrosoft.LCC.plist and trash that and net.steinberg.elicenser.plist
  3. Install the latest e licenser app then UNPLUG the dongle
  4. re-Boot Mac holding down the Command+Option+P+R and wait for the third bell then let up on the keys and let it boot and plug in the dongle after you are booted
  5. Run e licensor app and see how it goes.


    These are the things I always do BTW

Ah ha! thankuverymuch.
In my case Logic would not see any Steinberg Absolute 4 plugs. This fixed it - allow Synopsis for Logic.

Select System Preferences… from the Apple menu.
Open the Security & Privacy panel.
Select the Privacy tab.
Select Automation in the list of options on the left as shown on the screenshot below.
The Steinberg program that needs to access Synsopos.app should now be listed on the right.
Check Synsopos.app beneath your Steinberg program’s entry.

Thanks a lot guys, your help fixed my eLicenser and now I can open eLCC and it seems all is fine there.
I can now run VEP7 without a problem.

I still have a weird problem with Cubase Pro 10.0.50.
When I run Cubase a prompt appear and says that I have to activate the Cubase license in the eLCC. In my case it it activated there and the dongle works perfectly in High Sierra computer and in Windows 10 computer.
Here is the prompt image:

If I press start Cubase, it boots but there is no audio even I select an audio device. If I try to quit Cubase it freezes and I have to force quit.
How can I fix the “Demo” mode error?

Any ideas?

Hi,

Could you attach a screenshot of the right team of eLCC application, please? Make sure all numbers are blurred.

Here is a screenshot of the eLCC below.

  1. As you see the Cubase Pro 10 has a “Full” license.

  2. I wonder why there is another “Steinberg non-movable” license (Demo) on top, in case I have never downloaded or used any Steinberg Demo.
    The problem is that there is no “trash” icon there so I can remove that item?

In addition, the dongle works without problems in High Sierra and Windows 10 using the “Full” Cubase Pro 10 license.
I guess 2 “fake Demo” license was added during the time when I could not run the eLCC application…
Is there a way to remove it?

Thanks in advance!

Hi,

  1. That’s seems to me OK. Do you start Cubase 10 or 10.5 by any chance? For 10.5 you would need 10.5 license. In this case the Demo license would be used.

  2. This is factors preinstalled license. Every new USB-eLicenser comes with this license.

Opps, it seems I have missed that the 10.5 needs a payment. I’ll pay the update and try soon.
Thanks for your great help here!