Macros actioned from key commands work intermittently

Wondering if anyone else has experienced this? I’m using Nuendo 11.0.0. If I assign a key command to a macro and try to use it, it doesn’t always work. Selecting the macro from the Edit>Macros sub-menu always works but of course it’s pretty slow if you’re doing something like pasting room tone over and over.

Thanks for any and all help.
Scott

Probably those keys are assigned elsewhere on your machine.

Really, without knowing the most basic details, such what OS, what keystroke, what command, there’s nothing else that can be said! :smiley:

Thanks for the quick reply Steve. I’m on Windows 10 Pro (up-to-date). I was sure to use something that wasn’t already assigned to any other key command (the [ bracket). In this case I assigned it to a simple macro that I created which takes a range selection, moves it to the track below, copies, moves back up and then pastes.

Again, if I manually select this from the menu, it works without fail. And a lot of the time the key command works fine as well but sometimes it just won’t do it.

hm… but if you assign [ to a single key command it does work?

what’s the macro?

Yeah, that’s what’s interesting. So I did a test where I replaced my Return to Project Start (RTZ) command with the same [. 10/10 times it did exactly what I expected it to do. I’ve also changed the key command three separate times now on my macro, each time making sure that the key command is not previously assigned to anything else. It’s wacky no matter what the key command I assign.

What I have discovered is that the behavior is even weirder than I initially thought. Each time I use the key command (and it doesn’t matter which key command I assign it), it’s like a game of chance. Here are my options:

  1. It works as it’s supposed to on the first press
  2. It works as it’s supposed to but I have to press the button multiple times for it to do anything
  3. It pastes the selection to a new track below the tracks I’m working on and often extends my range selection for no reason.

The macro is one I made and is very simple:
Macro

So I make a selection

Then I hit the key command for the macro which should do this

But then sometimes THIS happens: (notice the new track where it pastes the selection and the extended selection on track 1). I haven’t hit any other buttons.

I’ve been using Steinberg software for about 20 years and I’ve never seen such bizarre behavior. Do you think trashing the preferences may fix an issue like this?

I should mention that I’ve also tried toggling “Cycle Follows Range Selection” to see if that would change the results and it was of no use.

And again, if I action the macro from the macro menu, things work perfectly each and every time. :thinking:

and that’s what’s effed up. If it weren’t for that, I would have been thinking about the macro firing too fast.

Could there really be a difference between firing the macro with the from the menu or with a keystroke?

So, yeah, I would try safe mode; disable prefs.

Maybe, though, the more hard core method of renaming the User Settings folder, %AppData%\Steinberg\Nuendo 11_64\, in order to fully reinitialize Cubase will give a cleaner result from a troubleshooting standpoint.

I disabled the preferences in safe mode today and got the same weird result so I’m thinking deleting preferences probably won’t do the trick.

I haven’t renamed the user settings folder yet so that’s still worth a shot.

As an FYI for you though, I broke the Macro into 2 different commands:
Move down + Copy (Key command = [ )
Move up + Paste (Key command = ] )

Works like a charm. So now I’m wondering if the macro does fire too fast…?

I’ll figure it out either way…I just wanted to give you that bit of information and say thanks for taking the time to put your brain to this. If and when I get it figured out I’ll be sure to update the post.

Regards,
Scott

A “classic” possible source of macro issues is the size of the project and the number of events ans redraw speed in the open project.

Try the macro in both a large and almost empty project to see if this may be the issue.

1 Like

Thanks Erik, I’ll give it a look in a larger project. So far I’ve only tried it in very small projects.

Cheers,
Scott