Macros and Launchpad - trying to make Cubase a looper


I use the cycle feature a lot when I’m writing music. I tried Ableton Live but didn’t really like it. I would much rather use cubase but with a few features that help working with cycles.

I’m making a bunch of macros for cycles but running into a number of issues.

First, the ones I’ve got to work. I’ve made the following macros and mapped them to buttons on the Launchpad:

  • Create a 1 bar cycle at the start
  • Move the cycle back / forward one bar (ie the left and right cycle markers)
  • Enlarge / shrink the cycle by one bar
  • Double the size of the cycle (duplicating the contents of the cycle)
  • Duplicate cycle to the right (and move the cycle markers to the copy)

…which are mapped to the buttons at the top of the launch pad.

  • Mute track 1…8
  • Solo track 1…8
  • Rec enable track 1…8

…which are mapped to the main grid of buttons on the launchpad.

The functions I’m using seem to be spread around the macro editor, the project logical editor and the editor for the generic remote control device. Which is a bit of a pain. For instance there are commands in the device editor for muting a particular (midi) track. But I can’t find anything like that in the macros.

Which means I’ve got some things I can’t work out how to do. For instance:

Deleting the part in the cycle for the selected track.
This would require a sequence of commands like select track, select part, delete. Because it’s a sequence it would have to be done with the macro editor, no? But the macro editor can’t select a particular track. The device editor can but it can’t string together a sequence of commands and map them to a single button on the launchpad. Hmmm. And in either case I can’t see how you select the part(s) of a specific track that are inside the cycle. You can select everything inside the cycle, or every part of a track, but I want the intersection of the two.

Copy the current cycle to the end of the song
This should work in theory but goes wrong in practice. My macro goes like this:
Range - copy in loop
Transport - to end

This sequence works if you do it by hand but when you run the macro it pastes in the wrong place. It pastes wherever the cursor is before the macro runs. The cursor does indeed move to the end of the song after the macro but it’s as if it doesn’t move “fast enough” for the paste command. I’ve tried adding various commands between the “Transport - to end” and “Paste” but haven’t got anything to work.

Ultimately I’d like to send midi back to the Launchpad so I can change the colours of the buttons, to show the mute/solo/rec status of each track, but I can’t see how to do that either.

Can anyone help with any of these issues? If I get the thing working well I’ll post up my macros here.

It’s a shame cubase doesn’t have some kind of scripting support. Do VST plugins have access to things like tracks, parts, cycle markers etc?

I should rename this thread “Generic Remote Device Weirdness”…

I made a couple of KC macros, one to select the parts inside the cycle of a particular track. Another macro to copy everything in the cycle to the end of the song. (see the attached images).

The macros use a couple of PLE’s that do the selecting (see images).

If I assign these KC macros to the computer keyboard they work fine. If I configure a launchpad button to run the macro using the Generic Remote Device then neither macro works properly.

The “select 01” macro selects the parts but won’t select the track.
The “copy cycle to end” macro, as described before, pastes into the wrong place.

Is that some weird bug in the Generic Remote Device?
Any ideas what’s going on here or how to work round it?

macroScreenShot by Alan M Jackson, on Flickr

PLEScreenShot1 by Alan M Jackson, on Flickr

PLEScreenShot2 by Alan M Jackson, on Flickr

The macro system in Cubase is flawed at the moment. It will randomly not do some of the actions. Basically makes anything a little more complicated unreliable. I guess there’s a really low timeout for the macro steps so the program doesn’t get into long freezes while it’s inside a macro chain. The workaround hints at this, as this problem is helped sometimes by adding dummy actions in the middle of the relevant ones. So you could try adding some extra steps that don’t do anything between your relevant macro steps and seeing if that works.

Really wish Steinberg would overhaul the macro system. It’s now frankly better to just avoid those unreliable action chains, as even the effectivity of the workaround will depend on the situation.

Can you recommend any good dummy actions to pad out the macros?

I’ve tried some “step bar, step back bar” actions but that didn’t work.

It’s odd that the macro works when triggered from the computer keyboard but not from the Generic Remote Device.

I’ll try a different device, check it’s nothing odd about the launchpad itself.