Maddening Audio dropouts are back Cubase 9.0.3

Again, I’m having audio dropouts so often it’s impossible to get any work done.
My interface is a pair of Delta 1010 PCI cards with breakout boxes. I’m running Cubase 9.0.3

Actually, they have never completely quit over the last couple years, but for months at a time they’ll become uncommon enough that I can work effectively. Then suddenly they come back with a vengeance. It happens during recording or playback with equal frequency, and is often accompanied by a cryptic error box saying “Rcording Error:Too many tracks recording”, even though I’m only recording one track. (Seriously, Steinberg, can’t you code meaningful error messages?)

I had a thread on this topic awhile ago, but now I can’t find it. Steinberg has an article on the subject, but it attributes the problem to bad NVidia video drivers, which I don’t even have (my system uses Intel drivers).

I’ve tried purging my prefs - somestimes it seems to help for awhile, other times not. I’ve tried turning off all startup routines I don’t need. I’ve tried uninstalling Adobe Reader (thinking its persistant “updater”, which can’t be uninstalled or disabled, might be the culprit.)

I can’t remember for sure, but I don’t think this ever happened with any 32-bit versions. Oh how I wish I could go back to Nuendo 2.0. It never gave me any problems, and ran way faster than any subsequent versions (I upgraded Nuendo through N5, then switched to Cubase 6). But of course each new version included features that I got accustomed to using.

I’ve accumulated quite a collection of plugins. Is it possible one of them is the problem (even if I’m not actually using it in a project)?

I’ve tried LatencyMon, and spent a lot of hours trying to understand what it was telling me, mostly without success. It seems to say I have a high “Hard pagefault resolution time”, but I can’t figure out what might be causing that. It also sometimes shows a high “interrupt-to-process latency” but doesn’t tell me what process(es) is having the issue. (FYI, I started it running about 10 minutes ago, and so far it shows no problems, and says my system is “suitable for realtime audio without dropouts”. Meanwhile, Cubase recording and or playback ‘stutters’ continuously while LatecyMon is running.)

Just about a year ago I upgraded my system to a 1TB Solid State drive, doubled my RAM to 16GB, And did a clean install of Windows. What an incredible pain that was! Took me weeks to get the system configured again to my liking, AND it had no effect on the audio drop-out problem.

Any suggestions?

Try this… a regedit hack to disable core parking. Had huge effect here:

Other than that, can’t help thinking that it may be your two delta 1010 PCI cards that are the culprits. These are very old, and a hi-end USB interface would be a much better choice today.

Are you getting the same amount of dropouts with only 1 Delta card in the box? I.e. if you remove or disable one of them?

You should run LatencyMon without running any other applications. So don’t run Cubase simultaneously! Just let it run for a while and it will tell you what the offending drivers or processes are. Also pay attention to DPC values. Other than that make sure you use the Steinberg power plan (at the Asio driver section) or even better make a a high performance power plan of your own. Set all sleep settings to ‘never’. Also make sure you have switched off all CPU throttling settings like c-states & speed step in the computer’s bios. Also turbo mode can cause issues because of the constant varying cpu speed.

You may be right. I have a visceral objection to retiring old workhorses that are still plentiful and inexpensive, but are no longer supported. It may be time to let go of them, bite the bullet, and get a new interface.

But I’ve always been apprehensive of USB interfaces, afraid that they would have monitoring latency issues. I typically have the ASIO buffer size set to 128 though I have in times past been able to set it as low as 64 without problems. I recently bumped it up to 512, which seems to have reduced the dropouts slightly, but there is an audible delay during recording. Would this not be worse with a USB interface?

I can’t remember for sure, but I think the problem may have started (or gotten worse) after adding the 2nd Delta unit. I’ll try taking one out when I have some free time and see if that helps.

I tried a few more things suggested here and here including:

  • Set process scheduling to “Background Services”
  • Set Power Options to “High Performance”
  • Disabled System Sounds
  • Disabled Visual Effects (then had to tweak it, as Cubase will not run unless an “Aero” theme is active)
  • Disable Network Connection
  • Disable Firewall
  • Disable Antivirus

No change.

I removed the 2nd Delta PCI card.

Problem persists.

Next, on the off chance that the Delta card has a malfunction in it, I’ll try swapping it with the other card.

Tried that. No change.

I found a “Turbo” CPU mod in the BIOS and disabled it. No change.

I have a Focusrite 8i6 USB interface I got cheap awhile ago to have for a backup, but have never used. Maybe I’ll try setting it up and seeing how it works.

Okay, I installed the Focusrite unit, and switched Cubase to the Focusrite ASIO.
Same thing happens. Plus I got a “Blue Screen” crash. (I’ve had these before, about a year ago, but they haven’t happened in so long I’d forgotten about them.)

So then I completely uninstalled the Delta interface including the ASIO driver, and tried Cubase playing back a recent project with the Focusrite interface instead. Still get audio dropouts just as bad.

So I don’t think it’s my interface. Could it be hardware? Bad motherboard? Bad RAM?

I also tried adunion’s suggested registry hack. Also no effect.

HOWEVER, I have just made an interesting discovery.

I opened a DIFFERENT project, one I recorded a month or so ago, and it played through with no problems. So I opened the more recent project that’s driving me crazy (keeping both projects open). It drops out repeatedly. Then back to the older project (with the problem one still open), and no problem.

I’m pretty much convinced now that there’s something in the project file that’s causing the dropouts.

So, I backed up the “clean project” to a new folder, delete all its audio content, and copy and paste the audio from the problem project. Ta-da, it works fine. (So far, at least, I haven’t tried recording, only playback). But I’m baffled as to what might be causing the problems in the “bad” project.

The “bad” project contains no plugins that aren’t also in use in the “good” one. There’s no audio clipping. No unusual routing, high levels, intense effects, or anything else weird that I can see.

Then I tried deleting the “peak” files for the problem project (I’m not totally sure what they do, but I’ve read that when deleted they automatically regenerate on reopening the project. Now I can play 3/4 of the way through the song before I get a dropout. Still unacceptable, but an improvement. Not sure if it means anything.

Now to reinstall my dual-delta setup, then try again. If the “new” version (made using last month’s “good” project as a template) continues to work with no dropouts, I’ll save it as a template, and see if it continues to run clean as I use it to create future projects.

You might try installing the original chipset drivers. I’m on Windows, but that cured it for me.

I was having numerous instances of audio dropouts and it was driving me mad. Someone mentioned to me that he had benefited from a a driver update for his graphics card. So I duly updated my AMD Radeon’s drivers to the latest version and I have not had a problem since. I can only guess that you might be using software that requires the latest update for the gui to run seamlessly. It’s worth a try.

Do you mean going back to EARLIER drivers, ie, UNdoing more recent driver updates, and reinstalling the ones that came with the motherboard? I did this awhile ago, and it made no difference.

I have integrated Intel HD Graphics. I’m pretty sure I updated the drivers awhile ago, and then later restored them to original.

I’ve just now updated Graphics driver to the latest version. We’ll see what effect it has.

I REALLY appreciate all the suggestions.

I’m 99% convinced now that the problem is NOT in my OS or hardware, but is the result of corruption within the project files themselves.

Late Friday I found an earlier project that played without dropouts. Since then I’ve created several new projects using that one as a template and have had no problems, even while running other programs (Word, Chrome Browser, Quickbooks, Windows Media Player) at the same time.

I think I may tend to perpetuate the problem by my practice of starting new projects by “cloning” an existing one (Backing it up to a new folder/filename after deleting its audio contents). I don’t know if this is common or recommended practice, but I find it much more convenient than starting new projects from scratch.

But it could still be that my dropout problem, which has been intermittent for a few years now, has just entered its “dormant” phase and things will run fine for awhile. I’ll report back if it happens again, or if I gain any new insights.

The audio dropouts are back…

Is there anyone who can help interpret Latencymon results for me? Most of it is Greek to me. Again it suggests I disable CPU throttling. I have power management set to high performance mode, and am pretty sure there is no SpeedStep or any other kind of CPU throttling enabled.

It also warns me that CPU speed “Reported” is 3109 MHz, but “Measured” CPU speed is only 1 MHz

I ran CPU-Z and it shows core speeds jumping back and forth between 3108 MHz (x 31.00) and 1604 MHz (x 16.00). What does this mean, and is it relevant?

This is driving me crazy (and costing me a lot of business). I’m thinking about getting a new computer, but if I don’t know what’s wrong with this one, how can I be sure I won’t just recreate the problem with a new one?

I found some suggestions in this SOS thread, particularly looking at the Windows Event Viewer.

When I did, I more than a few Errors, among them quite a few Disk errors indicating bad blocks on my project drive. I was not experiencing any noticeable workflow problems outside of audio recording/playback, so it hadn’t occurred to me that I might have a failing drive.

I backed up and replaced the drive (I did lose some data that was unreadable, but fortunately nothing critical in any current projects), and so far, so good. I’ve spent a couple hours editing both audio and midi tracks, and have had no dropouts I’m not sure that’s the only problem, as Latencymon is still giving me the same warnings, but it seems hopeful.

I’ll post back after a few days, or if I discover anything else relevant.

Thanks for keeping us up2date, had this issue with a disk for more then years back, but it kept me putting extra time into this thoubleshooting.
I almost shot myself when after a month or 8 I replaced the faulty drive and the sun shined again…should have done this faster!