Main screen position

How do I get Wavelab Pro 9.5 to open the main screen where I left it on start?

Is it the position and size that don’t come back right, or just the size? Trying it here on Win 7 and Win 10, the position comes back right, but the size comes back extended.

I also notice with the maximize/restore down button that maximize works ok, but restore down doesn’t restore down on 9.5.25. The restore down works ok on Wavelab 9.1, but not on Wavelab 9.5.25.

I have Wavelab on two screens. Left = Control Window 1 with some metering inside, right = the main window. Both windows are maximized, the scenario is defined as standard layout.

Everytime I open Wavelab, both are maximized on the left screen (which is my main monitor with taskbar), the Control Window upon the main window. So size is right, position is wrong.

This started to happen suddenly in Windows 7 with WL 9.5.1, didn’t change with the current update. Didn’t care much as I was about building a new computer - here it’s the same thing on Windows 10 64!

What do you mean with “here it’s the same thing on Windows 10” while your signature mention “Windows 7”.

Oh sorry, signature updated, new system running just since yesterday :wink:

I meant I had messed up something on my old computer and did expect that the different Wavelab windows would just stay where I’d place them on the new due to a complete new installation.

WL 9.5.25

I’ve just tried on W10. Left main, right control window 1. Both are not maximized, but are nearly full screen. They open at the same position and size each time!


Thanks Jim. I was talking about a single monitor and a single Wavelab window, before I knew Marqs was talking about dual monitors and main and control windows. I don’t think what I found has anything to do with Marqs dual monitor problem. But good to know your dual monitor setup works, (but reversed from Marqs ? (left main, right control?)).

What happened for me, on a single monitor and single window, consistently on Windows 7 and Win 10, is if you size Wavelab down to a small size and move it off-center, then close Wavelab, then reopen Wavelab, the window will open at the correct position, but the size will not be the same as you left it - the size will be extended (larger) horizontally and vertically.

Also the “restore down” function of the “maximize/restore down” button doesn’t work in any case for me in Wavelab 9.5.25, while it works fine in Wavelab 9.1.

For me, it would be good to know if anyone could confirm what I’m seeing, but I don’t think it has anything to do with Marqs problem.

MarQs, I just wondered have you tried > Workspace > Layout > Save Current Layout As Default. I guess you shouldn’t have to, if the problem only started with a Wavelab update, but it might be worth a try.

But good to know your dual monitor setup works, (but reversed from Marqs ? (left main, right control?)).

That’s correct.


Yes, I tried.

Does anybody have a new idea for me?

The problem still persists - no showstopper but a little annoying.

Wavelab’s main screen (the wave-window) appears on my computer’s main screen (the one with the task bar), whatever layout I save.

If I change the main monitor in display settings to another physical monitor, WL’s main window will be there on startup. For certain reasons it’s not practical for me to have my task bar on the screen I want Wavelab to open at ;-/

Any solutions to this?