Major Midi Timing bug in Cubase 8

Cubase 8 (all versions) has major problems with inaccurate midi timing. No such problem exists in Cubase 7.5.4.

The problem is midi notes are recorded a little before or after you play them. Cubase uses an internal buffer of a few ms, and notes can only be recorded at the beginning or end of the buffer, even if you play them in between. (I believe it’s a form of midi buffer jitter.)

You can tell the degree that you are suffering the problem by opening Midi list editor. It’s very obvious once you know about it, though somewhat subtle which is why I believe this problem hasn’t been reported before.

Let’s say you’re using a Midi Display Resolution of 120 ticks and playing notes that fall on beats. If you’re like me your timing will be slightly off but notes generally fall somewhere between about 20 ticks early to 20 ticks late. The notes will be totally random in between so you could have one that’s 3 ticks late, one that’s 7 ticks late, one that’s 15 ticks late, etc. This is how Cubase 7.5 behaves.

But when Cubase 8 is acting up, you can only record about every 10 ticks. So notes will all be 3 ticks late, or 13 ticks late, or 7 ticks early, or 17 ticks early, but nothing in between.

Obviously this totally destroys the musicality of the playing.

Sometimes Cubase 8 won’t “act up” as much for me, and the Note On times are recorded normally. But upon closer inspection, the Note Lengths exhibit that “every 10 ticks” bug.

The dead giveaway that this is a Cubase bug is I just was working on a project that recorded normally for the first 8 bars, and then at bar 9 Cubase went into total bug mode. I do have a tempo change there, so I thought I might have just finally figured out a possible source of the bug. But I have a tempo change at bar 5 too and that doesn’t cause any problem. And anyway, if I just create a new project with a fixed temp, it will always exhibit some form of midi timing problems, so it doesn’t look like this bug is related to tempo, at least not solely.

I have reported the issue to Steinberg and they can’t fix it as of now. We tried email support, phone support, and I sent them project files demonstrating the problem.

Of course the first thing I did was adjust every single possible Midi or other setting (timestamp, buffer, delay compensation, etc.) but none of it has any effect whatsoever - this is definitely not a configuration issue on my end.

To repeat, Cubase 7.5 works 100% perfectly for me so it’s not an issue with my hardware setup either.

I would advise anyone recording Midi in Cubase 8 to look carefully to see how much this issue may be affecting you.

Mine is dropping held notes/cutting them off. Where is the midi buffer at? Would adjusting it help me on my playback drop-outs, thanks :slight_smile:

I learned that this is probably Midi buffer jitter from this Sound on Sound article, which has pictures and a description of a problem very similar to the bug in Cubase 8:
http://www.soundonsound.com/sos/dec07/articles/cubasetech_1207.htm#para6

I think the ASIO buffer may affect Cubase internal Midi buffer in some way, but there is no way that I’m aware of to directly adjust the Midi buffer.

Thanks, I’ll read the article and try to make adjustments. I’m going to try using cubase 7 and see if I can reproduce the cubase 8 problem by playing the same thing.