Major Plug-in Bug in WL 7.2

I just spent over an hour trying to open Wavelab 7.2. It keeps telling me that caused a crash the last time it was started and gives me the option of YES place it in a folder or RETRY. I keep saying yes but then it just goes to the next plugin and does the same thing. It has gone though almost my whole VST plug in list.

What is going on here??? I never had that problem with WL 7.01. or WL 7.0. This is ridiculous… it won’t load any VST3 plug ins and so far none of my VST 2.0 plugins and it won’t load Waves at all.

What should I do???


All I can say is I feel for you. Your report has is now convinced me to not install 7.2 as I do not have any time to troubleshoot a problematic update. This one seems to have a larger than usual number of nasties…


Yeah, I would avoid 7.2 (at least for Mac)…my Waves and UAD VST-3 load ok…but it seems that all 3rd party plugins have a major graphic errors that cause them to be erratic. They go white, can’t close them without clicking the show/hide in the master section and they always reopen when switching apps.

Major issue.

Is the last version of 7.1 still downloadable?

I think i may even have the install file, will I create more problems by trying to go backwards or does it generally work to do that?

@Thomas W. Bethel

You should erase the file C:\Users[user name]\AppData\Roaming\Steinberg\WaveLab 7\Cache\plugin-cache-*.txt
(assuming you have Windows 7, else look into C:\Documents and Settins[UserName]\AppData\Steinberg\WaveLab 7)

Reboot. And Relaunch WaveLab.


Is this required for everyone to do? Or just in this specific case?


No, this is a specific case. This sounds like a system problem, hence my suggestion to clean and reboot.

I am still on Wondoze XP and I will try this and report back. Thanks! for the quick reply. You are the best PG!!! :smiley:

The fix worked, but of course I lost all my presets. So far so good. Thanks PG…as always - you are the best.

I saved my session in WL7.2 and when I went back an hour later to open the session the same thing happened as I described in the first post. Does this mean a bug or something I did wrong? It took me about an hour to try to get the 7.2 to work before I posted the problem here, about an another hour to get things back the way they were after implementing PGs fix and now another hour to redo it yet again. The project was 15 minutes long. I guess I will take everything off the computer and put WL7 back on and then 7.0.1 and leave it at that. What could be causing this bug???

WaveLab scans a plugin if its date has changed or is new. Normally this happens only when installing or updating plugins. If that is not the case and that happens, something could be wrong in your system. The fact that WaveLab also keeps telling you that caused a crash the last time it was started, is abnormal (this message is normal, but the crash is abnormal unless the plugin has/causes a problem). Communication between WaveLab and the plugin is made by small file accesses. This could be also the sign that something is wrong. Therefore I recommend you to run a scan for errors on your drive, and also to defragment your hard disk. And reboot.

This scanning process is the same in earlier WaveLab 7 versions. The only difference with the past, is that there is now a separate cache file for each installed version of WaveLab on your system (plugin-cache* file).

I did scan for errors on my drive, I defragged my C:/Drive I ran all the drive check programs I have access to and they all came up saying there was nothing wrong with my drive. My WL version 6 runs just fine on the drive. I had no problem with 7.0 or 7.01. No abnormalities in other programs like Samplitude or Vegas10. I am going to take off WL7.2 and reinstall Wavelab 7.0 and then upgrade to 7.01 and leave it at that until this gets sorted out.

OK so I started clean with a fresh install of WL7.0. I installed it and closed it and reopened it and everything was OK. I moved some windows around and closed it and opened it an it was fine. I applied the WL 7.2 patch. I opened WL 7 and it took a long time to go through all my plugins. I then closed the program and reopened it and everything was fine. I opened up WL 7.2 again and it was fine. I moved some windows around and closed the program and when I went to open it the installer went plug in by plug in as it had done previously when I first reported it on this forum in my first post. So I went back took WL 7.2 off my computer and am in the process of putting 7.0 and the updates up to 7.2 on my computer. Any other ideas???

Sorry, no clue at all. It’s like if all your plugins were modified, or if the wavelab plugin cache was erased, or if the wavelab application path was modified. None of these cases are normal.
You could activate the diagnostcs to know the cause. Press alternate and open the main preferences, then on the diagnostic tab, activate plugin scanning. Quit wavelab, and before running it, run tracer.exe found in the tools folder. This will give hints about why certain plugins are rescanned.


More mystery and a GREAT outcome.

So I uninstalled WL7. I reinstalled it and then installed the 7.0.1 550 patch. The computer said it had to reboot and when it did and I started WL 7.0.1 550 it said it could not find the dongle.A message window came up telling me to update the software for the dongle which I did. I reopened WL7.0.1 550 and it worked like a charm so I updated to WL 7.2 and presto everything is working correctly with no problems. When I originally put WL7.0 on my computer I had updated the dongle software as part of the upgrade so the dongle software was not that old. I am running Windows XP Pro SP3 as my operating system and the drive is fairly new as is the operating system since my old drive crashed and I had to do a fresh install on a new drive.

Thanks for all the help!

Thanks for the input.
Note that all wavelab 7.x.x versions are not patches: they can be installed without the presence of any earlier version.

Yeah I updated to 7.2 today.

I noticed the same problem on my MAC Pro you describe here. Plugin windows act strange, some become white, some just leave the GUI visible even if plugin is hidden. So new patch is needed:)

Good thing is I can move Nugen VisLM and Visualizer across the screen now. In previous update both plugins were unmovable.

Any tips PG?


I have corrected the following issue, and trying to find other possible cases:
“When hiding certain Master Section plugins (“Carbon” plugins), then switching to another application, then switching back to WaveLab, then the plugin window could popup and become white or could not be moved anymore.”

Thank you, let’s hope for a 7.2.1 very soon.

Observation regards PG system problem comment.

This happened for me after a Wavelab load crash generated by an exception error on trying to load Image Line Fruity Loops Studio v10-2 VSTi plugins.
After the crash the effect reported occurred on next load so I had to apply the solution PG advised.

It appears not so much a system problem but a software compatability problem.

Wavelab update on Windows 7 32bit.