Make Into System command not working (in a specific case)

I want to move the single bar staves in the last page of a score into the next-to-last page, since there was enough space there.
I selected the relevant staves of the two pages and switched to Engrave Mode, but the Make Into System command did not work.

I discovered this was due to a clef change in the last bar of the next-to-last page (just one instrument). After I removed the clef, Make Into System worked as expected.
Of course I had to re-write the clef change, which was not a big deal on a single instrument, but could be a little annoying if a lot of instruments are involved.

If you have a copy of the file with the clef change still in place, or can share an example project that demonstrates the issue, that would be interesting to see.

In particular, I wonder if the “manual” make into system method of inserting a system break where you want the forced system to start, then activating “Wait for next system break” in the Properties panel would work.

Hi Lillie,
I attached the score where I found the problem. I deleted the music content of all the systems except the next-to-last and the last, because the score is a transcript (still incomplete) from a copyrighted music book, but the page/frame breaks and clef changes were preserved.

To reproduce the problem, go to page 6, where you will clearly see the clef change on the last bar of the Piano (“P.”).
Try to add the last system (page 7) to the page 6 ones with engrave> make into system. This did not work on my system (Dorico Pro 5.1.0 on Windows 10).
If this happened to you as well, delete the clef change and retry.

I will also try your suggested “manual make into system method” in the next hour or so.

Thanks for your help,
Massimo (Milan, Italy)
make_into_system_test_case.dorico (3.5 MB)

Hi Massimo,

I don’t experience any issues moving that last bar from p7 back onto p6 with the clef change in place – whether using the “move bar to previous system” command, make into system, or the “manual” method.

Admittedly, as a member of the development team, I’m running a slightly more recent version of Dorico 5, which could possibly be a factor.

What exactly did you select in the last bar before doing make into system? Where you select in the bar can affect where the resulting system breaks go.

For the record in D5.1.10.2081 (the latest release) I also can pop the last measure over to the previous system/page without issue.

Hi Lillie,
About how I selected the bars 54 to 59 to make them into a system I used two methods:

  1. Selection by system track.
  2. Bar-range selection: click-to-select on bar 54 of 1st instrument (“V.”) followed by shift/click-to select on bar 59 of last instrument (“Ch”).

The behaviour of the engrave>make into system command is the same (doesn’t work with the change clef present/works with change clef removed).

But there is one important point I noticed after selection (both methods): no clefs were selected (highlighted), except the one on piano at bar 59 and its corresponding change clef symbol in the previous system.

At this time I deselected either clefs with CTRL/Click (the other one being deselected automatically) and Voila, the Make into System Command worked!

Do you see the above keys selected in your case?
My Dorico version is (the same as lafin: I will reply to him for some confirmation).

At this point the workaround is so simple that I can wait without problem until the issue is clarified.
Thanks again,


Hi lafin,
thanks for your verification that the command worked for you (with the same Dorico version I have installed!). My question is: did you verify the “make into system” command directly on my test case?

This could be due to your selection method: Dorico isn’t like other software you might be used to, you don’t have to select everything that you want in the system. A single item at the start, and another single item at the end, will suffice.

See the instructions here:

As to why only one clef was included in your selection: “prevailing” clefs that are automatically part of the preamble aren’t really “items”, they’re just automatically shown. Explicit clefs that you have input are, however, items that you can select and move.

Hi Lillie, I marked your last post as the solution.
Thanks for the time dedicated to this post,