Make MIDI follow tempo track?

I imported a audio track,
Did a tempo detection and stored the tempo track,
Then i made a 1 measure midi groove and copied it to all the measures of the imported audio file.
It seems the MIDI doesn’t snap to the tempo, and soon it is out of sync with the audio.
I must be doing something wrong but what can i do to make the MIDI snap to the tempo track?


MIDI data has to always follow the tempo.

Could you attach a screenshot, please?

It is more clear if i zoom in, I moved the parts so they start on the beginning of the measure, it suppossed to be al 1/4 notes

Make sure the track is set to the Musical Time Base. The button is visible here.

But you should switch the track to the Musical Time base before the tempo changes. So I would recommend to switch to static tempo in the Tempo track first, make sure, you set the correct tempo. Then enable Musical Time Base on the MIDI Track, end then enable the Tempo Track again.


When I switch to a static tempo, the audio parts aren’t in sync anymore.
There also isn’t a correct tempo, the imported file (source for the tempo track) hasn’t a constant tempo.
It was hard to find the toggle Timebase, I don’t have it on the header of the tracks in the tracklist,
I found it in de Tiny buttons on the track in the left pane.
After i put the Groove Agent track in the note mode, the repeats worked and the midi track stays in sync with the tempo