Making longer MIDI WAV samples play shorter time

Hello.

I have this drum map of Groove Agent 4 SE and I have a Snare Roll sound saved under one slot. The problem is, that this snare roll is rather long (for the cases where longer roll really is needed) and when I create a MIDI note for that Roll to play it plays through its whole length.

So is there a way to edit the lengeth of the GA4 “notes” so that in this case the Snare Roll wouldn’t play anymore since there are “normal” snare hits coming along before it ends currently.

I tried to open the Instrument track with the MIDI Key Editor (instead of the Drum Editor) where the lengths of the MIDI notes are ajdustable but it doesn’t have any effect. This Snare Roll in this case just plays from start to very end undepending the length of the note.

Any solutions?

Drum sounds are usually played as oneshots, meaning the whole sample will play back once triggered.

Change the loop mode from oneshot to no loop.
This way the midi note length should determine how long the sample will play.

These settings should be somewhere under Sample tab.

Thanks man! I’ll try that!

Hi!

Sad to say but I couldn’t do anything to solve the issue.

First off::: where do you adjust the LOOP MODE?
Second::: Where is the SAMPLE TAB?

I guess what menus and choices you see, depends on what things (tracks, samples etc.) are selected/active in Cubase 8 so please try to help me a bit more here.

Attached are the pics of the DRUMS EDITOR & KEY EDITOR views of the Instrument track (which contains the drum “hitpoints”). Also there’s a ZIP-file attached which is a packed MP3 file of the output of one point of that songs under editing where I try to use Snare Roll correctly, so as You can hear, it’s way too long.

Please try to be as specific as You possibly can. Me and my severe ADHD ain’t a good combination for learning things :slight_smile:
sample with snare roll playing too long.zip (100 KB)
key editor.jpg
drum editor.jpg

Hi!

Sad to say but I couldn’t do anything to solve the issue.

First off::: where do you adjust the LOOP MODE?
Second::: Where is the SAMPLE TAB?

I guess what menus and choices you see, depends on what things (tracks, samples etc.) are selected/active in Cubase 8 so please try to help me a bit more here.

Attached are the pics of the DRUMS EDITOR & KEY EDITOR views of the Instrument track (which contains the drum “hitpoints”). Also there’s a ZIP-file attached which is a packed MP3 file of the output of one point of that songs under editing where I try to use Snare Roll correctly, so as You can hear, it’s way too long.

Please try to be as specific as You possibly can. Me and my severe ADHD ain’t a good combination for learning things :slight_smile:

In GA4SE go to Edit > Sample … There you see the playback mode on the left bottom of the edit window.
Change it from One shot to No Loop. Now you can adjust the length in the key editor, not in the drum editor.
You can also trim the sample in the sample editor if you want to.

But dude … Seriously, read the manual.

ADHD or not, why do you expect other people to explain every simple detail of a plugin to you, this is unreal.

I agree. We all like to help. But this is very essential and
the playback modes are a common setting for almost all samplers.
You’ll find out even more stuff which means more fun with GA4.

Cheers!