Map CC

Hello. I just bought Cubase 8 and went through the quicklearn tutorials. Love it so far. Coming from Live 9.

I have an Impulse 49 for my midi keyboard. With Live, I installed Novation Automap and all was well. Evidently, they don’t have an Automap setup for Cubase 8 yet.

The keyboard has 8 knobs on it. When I twist them the LED screen says CC#21 for the first, and on up to #28. How can I map those to control the quick controls assigned to a track?

I did figure out how to map the quick controls to the VST in the track, but not to my midi keyboard. I tried hitting learn and twisting the knob, but no mapping happens.

Also, on the right side of my screen I see track instruments. They have knobs displayed too, which correspond to the quick controls. However, there are pages over there. Will each page be controlled by the same hardware knobs the first 8 quick controls are mapped to, or how does that work?

Hi

Go to Devices and open Device setup.
Select Track Quick Controls.
Make sure you have your controler selected as MIDI input.
If the midi learn function doesn’t work for some reason, you can type in the controller knob CCs manualy where it says Address. Then click Apply.

Do the same for VST Quick Controls

You can use the same physical controller knobs for both VST Quick Controls and Track Quick Controls

Once you get it working it’s a good idea to export your setup.
Otherwise you may find your settings are gone when you start a new project.
It seems load last imported or exported setup as default.
TQC.JPG

I have an AKAI advance 49. I’ve been trying to map transport functions to the MIDI controller. When I try to map start, stop, record, cycle, etc., none of the addresses change when I click learn in the device setup. The only one that gets assigned is cycle. Start, stop, record, etc. do not respond at all. Everything seems to be connect correctly… Extremely frustrating :blush:

joikeeling,

start, stop and record require you to activate MMC in Cubase (Transport - Project Synchronization Setup - MACHINE CODE INPUT SET TO ACTIVE AND PORT 1 USB OF YOUR MPC BOTH FOR INPUT AND OUTPUT) )

Also you need to set on your MPC in your global settings the Transport Format to MMC
Also set the midi clock on your mpc to external

Thats it. Now your Play, Rec and stop will work. You cant map them since they are already internally mapped in your mpc (except for the cycle which is why you can change it in the remote settings)

Best,
Robert