Mapping an M-Audio Keystation Mk3?

Trying to map it to Cubase but struggling. No specific software or instructions from M-Audio.

Out of the box the volume slider controls ‘internal’ VST volume but assigning it as a Generic Remote allows it to control track or stereo out volume (plus other parameters) so this isn’t the problem.

My issue is the transport controls & “directional buttons” - it has a PLAY, STOP, RECORD & 5 extra buttons. By assigning a Mackie Control, the PLAY, STOP & RECORD work fine.

The up/down directional buttons allow cycling through tracks but the left & right buttons are a bit odd as they increase or decrease project window zoom!

The centre directional button seems to change the function of the other 4 - when pressed, the up/down now expands or contracts the track display & the left/right don’t do anything.

I can’t find any info as to how I reassign the buttons.

The keyboard can transmit Mackie, HUI or MIDI (but only one at a time) so I switched it to MIDI & tried creating a mapping using MIDI learn in Generic Remote. This seemed OK initially however when playing the keyboard strange things would happen like tracks being deleted!

Anybody got any advice? Many thanks!

Did you remember to disconnect your controller from the Mackie or HUI Control device in Studio Setup?

Otherwise Cubase will continue to interpret the regular midi commands you’re sending from your KeyStation as Mackie or HUI messages (since Mackie and HUI are just specific implementations of regular midi messages).

Hi, thanks for that. Sorry I’m a bit confused - with MIDI input/output not connected then surely that particular Mackie Control will have no effect, i.e. it’s like having no Mackie Control set up?

My point re: strange behaviour when playing the actual keyboard was when using the Generic Remote approach, i.e. no Mackie Control set up.

One issue I have with Mackie is that I have another controller (Arturia KeyLab Mk2) which is assigned under Mackie (so the Keystation would be Mackie Control 2). Unfortunately having 2 Mackie Controls is causing issues as some of the KeyLab functions stop working after I assign the Keystation.

Cubase just sees midi messages. By connecting your controller to a Mackie or HUI controls in Cubase Studio Setup, you’re telling Cubase that your controller sends a predefined kind of midi dialect, which uses Notes, CC’s and Pitch bend for all kinds of commands that are not actually notes and pitch bends.

By connecting your controller to the Generic Remote, you’re telling Cubase that you will custom define how to interpret each incoming midi message including the start and stop buttons.

One additional technique I employed to alleviate confusion in my setup is to program my external controller keyboard so that all of the midi messages that I meant for the Generic Remote, would come in on Channel 16 - and then I set up the Cubase Preferences midi filter to ignore channel 16. That midi preferences filter setting only applies to what goes to your tracks, but still leaves everything going to the Generic Remote .i.e. my keyboard notes are programmed to send messages on midi channel 1 and my play and stop buttons are programmed to send on midi channel 16.

p.s. I assume there is software by Arturia that allows you to program what your midi controller sends for each button and knob and on what midi channel it send that message.

Hi again, yeah the Arturia is mostly pre-mapped with instructions on their website on how to map the remaining buttons. M-Audio contains no such instructions. For example, I don’t know which Keystation buttons correspond with F1, Shift+F1 (as per Mackie Control buttons).

Thanks for the tips, particularly the MIDI channel 16 option, I’ll have a play…

So I’ve managed to create a Generic Remote with ch16 for the buttons, but then I have to manually select ch16 from the Keystation to get them to work. I could of course stay on ch16 but then I end up with the same problem with keyboard keys somehow triggering strange things like tracks being deleted!

Also, when assigning the MIDI input, what is the difference between “MIDIIN (Keystation Mk3)” & “Keystation Mk3” (& same for output)? My Arturia is setup with Mackie using the “MIDIIN (KeyLab mkll)” (instead of “KeyLab Mkll”) but when I use the MIDIIN/OUT for the Keystation Generic Remote I get nothing transmitted from the Keystation.

Well confused now…!

I don’t have any of the hardware you’re using, so I can’t answer your question directly.

In some controllers, one of the 2 midi device names refers to the physical midi outlet, which maybe allows you to plug in another midi device via 5 pin - effectively making your midi controller also into a midi to USB interface.

Some other controllers also split their internal midi sending into 2 different USB midi ports - one for playing notes, the other for sending some (or all) of the buttons like play, stop, etc.

To find out, try the midi monitor in Cubase to see what’s coming in from each of those midi inputs when you press various keys or knobs and twist various dials.

MIDIIN (Keystation Mk3)
Keystation Mk3

Thank you. I think I get it. It’s quite poor that M-Audio provide literally no information on mapping!

Using Mackie won’t work as it conflicts with my Arturia KeyLab Mk2 - apparently this is a known issue Arturia tell me. So I’ll have to use Generic Remote.

Bizarrely though after wiping all Generic Remote settings I now cannot use MIDI learn! Before, I managed to see & map the transport buttons (e.g. I’d press the play button & something like MIDI cc 114 would be listed in the table) but now the transport buttons won’t register. I’ve definitely set the Keystation to output MIDI from transport buttons (you can select MIDI, Mackie or HUI).

Something very odd going on. I’ve tried resetting Cubase preferences, no joy.

That’s a weird one, which I haven’t seen before - have you tried to make a new empty default template? Also maybe reboot computer?

p.s.: In my deep diving into the Generic Remote, I’ve also encountered frequent scenarios when my edits in the Generic Remote would just not become active. for those cases I’ve made myself a little checklist of things to try in (that order) to get my changes accepted.

I’ve posted it on my little blog (it was originally written for Cubase 10.5, but applies equally to 11):

I rebooted & deleted preferences again. Following another reboot it sprung into life! Very odd.

Thanks for the link I’ll take a look. From searching the forum it appears that Cubase is lagging behind other DAWs quite badly when it comes to mapping of MIDI controllers.

To be perfectly honest I only bought the Keystation for the extra key real estate so its (limited) DAW functions are not essential but it’s bothering me why I can’t get DAW mapping to work!

Thanks for your input with this, really appreciated.

1 Like

I found the Generic Remote stuff reasonably powerful, but also somewhat temperamental.

I can’t speak to comparisons with remote control of other DAWs though, since I’ve never been able to get enthusiastic enough to use other DAWs on a regular basis (even though I have full licenses for Ableton and Reason) . I just missed too many other Cubase features in those DAWs for the way I like to work.

That being said, I also wish Cubase remote control was a bit more advanced.

So I’ve finally managed it!

I think it was a combination of confusion on my part plus a slightly odd feature whereby the MIDI CC for transport & other buttons is sent on the “MIDIIN (Keystation Mk3)” port yet the volume slider MIDI CC is sent on the “Keystation Mk3” port (i.e. the same one as the keyboard keys). As such when I kept experimenting with the various ports I was tying myself up in knots!

The volume slider is by default mapped to MIDI CC 7 which affects the volume inside a VST (i.e. not track volume) & doesn’t require a Generic Remote setup. To map it to track volume, stereo out volume or any other parameter would require another Generic Remote setting up with a single fader & using the “Keystation Mk 3” port.

I think it’s playing with the volume slider assignment that led to the weird issues whereby playing a chord muted or deleted tracks (& other strange behaviour). I must have created a Generic Remote using the “MIDIIN (Keystation Mk3)” port, used MIDI learn to assign the buttons but not deleted all of the pre-loaded defaults that appear when a new Generic Remote is created. I must have then changed the port to “Keystation Mk3” in an attempt to change the mapping of the volume slider meaning that the keys were now triggering the various CC messages & commands.

So as mentioned above, to completely map all of the Keystation controls, 2 Generic Remotes need to be set up - 1 on “MIDIIN (Keystation Mk3)” for the transport & other buttons, & 1 on “Keystation Mk3” for the volume slider. I already have track & mixer control via my Arturia so will leave the volume slider as default.

Thanks for the inputs & I hope this thread is useful to Keystation Mk3 owners also scratching their heads about how to map it!

1 Like