Mapping Novation Impulse to Cubase 9

Hi,
I’m trying to map my Novation Imulse 61 to Cubase 9 but having problems. Tried to do it with “Quick Controls” and then “Generic Remote” following the procedure here

https://www.gearslutz.com/board/music-computers/721461-manually-mapping-impulse-cubase-6-5-a.html

but was unable to do so.

When I use the “learn” function in Generic Remote and move a fader/knob on the Impulse I can see the address move as it’s supposed to but after I “apply” and “ok” it, it still doesn’t work. Cubase can see the controller because when I move a control it’s showing on the “midi in” meter. Don’t think the Impulse is the problem because I was able to do this with an older version of Cubase. I have the latest updates from Novation. Restarting computer makes no difference. Any ideas? :bulb:

I’ve had some adventures with Novation’s SLMkii, which I suppose is similar. Recently https://www.steinberg.net/forums/viewtopic.php?f=250&t=119587 I’ve learned that you can set up the automap 4.9 server pretending to be Cubase 8 while actually doing all of the steps in Cubase 9 and it seems to work.

The gearslutz page is similar advice to the advice in the video I linked to. I don’t know why your changes are lost. BenW Focusrite didn’t mention the need to untick the learn box when you are done touching Novation controls. Maybe that has something to do with it. :confused:

Thanks Colin! :slight_smile: I’ll give that a go…

Hey Shay and Colin,

my name is Joshua - and I’m stuck in the same problem as Shay and as I guess even more users. I also followed the gearslutz advice, but Cubase and Impulse is behaving exactly the same way as Shay describes it.

Of course I turned off the learn check box before assigning the new settings in Cubase.

Just for Information: By using the advice from gearslutz it turns out that learning the 8 knobs to Cubase the CC Controller values changed it’s mapping from default CC 71-78 to CC 21-28. With absolutely the same result. Changing the value knobs is generating a Midi signal received by Cubase (what is fmho correct because we are sending from Novation a Midi-Control-Event f.e. CC21 to Cubase Input Midi Channel 1). But has no impact on the Quick Controls of the desired Plug-In or as far as I can see changes absolutely nothing within Cubase.

I don’t remember the source, but someone noticed, it may has a meaning to enable the flags “Send/Receive” both in Cubase Quick Control Editor. I’ve also done that with no effect.

Also from interest may have the meaning of the CC values itself. Midi Standard tells, the CCs 21-28 are UNDEFINED, while the default Cubase CC Values before learning were CC 71-78 is set kind of Sound Controller, like VCA, VCF and so on (usually CC 70- 79).

But I’ve found out a different approach.

How to use Novation Impulse 8 Knob Encoders with Automap 4.10 and Cubase 9

First of all you have to set up the Automap Server. My settings are like this:

Under the Tab Preferences:

  • Check Display Notifications for 5 Seconds
  • Focus Device is left blank
  • Encoder acceleration is fast
  • Check Follow on screen Plug In where possible
  • Check Pot/Slider pickup
  • Uncheck Disable learn

https://picload.org/image/dgrrwwil/picture01automapgeneralprefere.jpg

Under the Tab Software Setup:

  • Make sure your Cubase 9 is listed and marked with a green sign.
  • Under “Setup Wizard” (which isn’t currently available ) make sure the Impulse you are using is
    selected.
  • Under “Setup VST-Paths” make sure the correct Path to your VST Plugin Folders are entered.
  • Underneath “VST Paths” you will find a Box, where the following is listed: VST, VST3, RTAS.

https://picload.org/image/dgrrwwii/picture02automapsoftwaresetup.jpg

\

  • Click VST and a list opens with all Plug Ins found under the given Pathname. Make sure that all
    your PlugIns are listed here and also ensure that they are checked / enabled.
  • Click VST3 and repeat the above steps.

If you use / need RTAS do the same, in my case there is nothing selected.

https://picload.org/image/dgrrwwiw/picture03automappluginsfoundan.jpg

Now it comes to the tricky part (tricky, because I don’t get how this works and just found out by accident).

Under the Tab “Mixer/Plugin Settings” you will see on the left pane side your Impulse Keyboard Controller with a nice picture.

For the first time of installation Automap:
The right pane - headlined with “Name”, “Thing”, “Manufacturer”, “Type” was completely empty. After a while it filled itself for unknown reasons with some entries. In my case there are 3 identical entries named “MixConvert V6” Type VST3. All of them 3 entries shows up in them details with only 4 parameters.

Then there is an entry named “Cubase”, Type is “Mixer” which has 772 parameters.

https://picload.org/image/dgrrwwpr/picture04mixerpluginsettings.jpg

Now for the tricky thing. I am not sure about this, so I try to explain what happens without warranty.

I’ve struggled as many other user to remotely control the Synth Plugin Quick Controls, foe. Halion Sonic 3.
The Automap server has them mapped somewhere in the different pages you can select on the Impulse with the Plugin Page switch. By default you are on Page 1 and this controls maybe Volume, Pan or something like this.

For some reason I had turned off the Automap notification before. By testing around to get the QC working I enabled this function again with the result, that when I focussed the Halion 3 Plugin in Cubase, the Automap Server tells me that he is now Controlling the Halion 3. So far so good. The mapping was already weird in a kind of way, but suddenly I found out, that for unknown reasons a new entry appeared in Tab Mixer/Plugin Settings. It is called Halion Sonic, Type Instrument with 2048 Parameters.

We take look to the right and give the Button “Edit Mapping” a try.

It opens up a new Window named “Edit Mapping”. In the upper section you can find all kind of Load and Save stuff, underneath you’ll see the actual Mapping. In my case it shows correctly “Halion Sonic - Steinberg Media Technologies” Page 1/255.

Below that, you can see the board layout of your Novation with the Knob Encoder Section selected in a red outlined Box. More Down under you will see your 8 Knob Encoders dived in two Lines, each of 4.

The first page - where you are right now is mapped as follows:

S1 Mute - S1 Solo - S1 Volume - S1 Pan
S1 PChan - S1 Gn1 - S1 Gn2 - S1 Gn3

The means, when you turn Encoder Knob 3 foe. it will control the Master Volume of your PlugIn, in this Case The Halion 3.

https://picload.org/image/dgrrwwpa/picture05automapmappingeditorf.jpg

You need now to figure out how the Halion 3 QC’s are named and map them to the desired Knob Encoder on your Impulse. How to do that? To do that we need to switch over to Cubase. I expect you have loaded already your Plugin, in my case the Halion 3 as a Rack Instrument. You have created a Midi track with the PlugIn as Output and the Impulse as Input (this you can do in the Inspector on the left hand side).

In the Inspector you can find also a pane called Quick Controls. It can be switched on or of, in my case it is switched on. If you open this, you will find an option to load the standard QC from the selected PlugIn.

https://picload.org/image/dgrrwwpl/picture06cubaseinspectorqcfrom.jpg

In my case I can see the first one is named S1 QC1 Fliter.CutOff, the second entry is named S1QC2 Filter.Resonance.

So here we go. this are the names we need to find out for doing the mapping in the Automap Server.

For security reasons I do a backup of the Standard Automap Map to make sure you have the original when something while editing is going wrong. So we switch now back to the “Edit Mapping” of the Automap Server.

In the upper section click on “Save” and save the original Mapping under a unique name and location. Now we are ready to do our little Re-map Experiment.

We want the Encoder Knob 1 on our Novation Impulse to control the QC 1 of our selected Cubase Plugin Halion 3 Sonic.
First, click on the first Encoder Knob. It turns red and is ready for a new assignment. In my case the original Control Value is “S1 Mute”. That doesn’t work for me so we have to find the before discovered Controller name in Cubase for the QC1, which is in this case “S1 QC1 Fliter.CutOff”.

https://picload.org/image/dgrrwwcw/picture07automapeditmappingsel.jpg

In the lower pane of the “Edit Mapping” Window you will see a list of available Parameters, in case of Halion 3 there will be 2048. So we scroll down the list until we find our desired “S1 QC1”. In my case it is the 10th entry. If you click that Parameter, you will see the first Encoder Knob you selected before changed its description from “S1 Mute” to “S1 QC1”.

https://picload.org/image/dgrrwwir/picture08automapeditmappingsel.jpg

You will also see in your Impulse Display the new changed Parameter. So we go further and assign the other 7 Encoder Knobs with the corresponding Cubase Parameters. Just the same way you did on the first Knob. Just make sure you select the corresponding parameter in the lower pane of the Edit Mapping Window.

If you have done that your Knob Encoder Matrix should look like this:

S1 QC1 - S1 QC2 - S1 QC3 - S1 QC 4
S1 QC5 - S1 QC6 - S7 QCz - S1 QC 8

https://picload.org/image/dgrrwwia/picture09automapeditmappingsel.jpg

Just save this new Mapping as described before.

And now lets have a look if that works. Close the “Edit Mapping” Window, close the “Automap 4 Configuration” Window and switch over to Cubase.

Open up your PlugIn (in my case Halion 3) and check out if the Encoder Knobs on your Impulse are now able to control the Plug In Quick Controls in Cubase.

And what the hell should I say? In my case all Cubase Quick controls from 1-8 are gently responding to the Impulse Knob Encoders 1-8 for Halion Sonic 3.

Important Hint:

You have to do this reconfiguration for each Plugin you want to remap. It is depending on you, if you find the Standard Mapping useful or not. Also you cannot use a modified Halion Map for Dark Planet foe. or Loop Mash. They have all different Parameter Layouts and you have to make up one for each Plugin you are going to use. Make sure you save the Standard Maps before Re-Mapping. And also save your modified Maps to reload them if needed.

Unfortunate I couldn’t get Groove Agent SE and also Halion SE not running with Automap. Even I have specified the .dll file locations, they doesn’t appear in the Automap for unknown reasons.
Don’t know if this works for you too, but I like to told you how I solved this Problem for myself.

Regards

Joshua

Thank you for your detailed descriptions and the persistence that obviously stands behind it. I have yet to try any of this, being satisfied with basic functionality for the moment. Novation’s documentation and tech support are nearly worthless – a situation I’m sure they have trouble addressing (probably for financial reasons, but possibly because engineers hate doing documentation.) So it falls to us in the user base to carry on experiments and research, like unlocking the secrets of nature. Thank you again.

Hi Joshua,

thanx for this detailed description!
I have just noe problem with it : you say " Make sure your Cubase 9 is listed and marked with a green sign."
this steps failed for me and Cubase 9 is marked with a red sign…

do you know how I can do to make it be green?
did anyone have the same problem?

how to fix this?

thanks in advance for your help!
Nicolas