Marquee selection being wholly unpreditable

See video link. I’d understand marquee selecting more than what is physically inside the rectangle if I were selecting ties or beams (that’s what it says in documentation), but this is not the case here. What is the way to only select some (contiguous, subsequent) notes of a chord without extra ones (and why is so unintuitive)?

Imho, if this is somehow working as intended, it’s either 1) bad design 2) undocumented/documentation is out-of-date or 3) there should be an option in settings to adjust which objects are selected (“strict mode” selecting only, absolutely and nothing else except what’s inside the rectangle, the explained mode where ties and beams augment the selection, and whether all noted in chord are selected etc.).

I am aware of the padded bounding boxes of noteheads and how zooming affects the selection behaviour when clicking something, but surely the selection area of the top note of the last chord isn’t overlapping the two bottom ones?

Dorico 3.5.12.1066

If you marquee select the stem - as in the last chord in the bar - you’ll select the whole chord.

It is possible but only at a much higher zoom level than the one you’re currently working in.

I have a Respell Flats as Sharps button and a Respell Sharps as Flats button on my Stream Deck. All these buttons do is
a) filter for whichever type of note
b) Respell in whichever direction.

You could approach it from a slightly different angle, by setting keyboard shortcuts for the filter select/deselect toggle and filter notes in chords (top/second/third etc.)

Two suggestions. 1) Zoom in and you will find it much easier to select; 2) Select the the whole chords and use Edit>Filter>Notes in Chords. You can only do one row of notes at a time, but your frustration may be eased.

I’ll add that I did try zooming immediately (as I know the zooming affects selection precision), but that did not help. Always selected multiple notes.

If selecting just the stem (not beams or ties) selects all the notes, we have another issue, as I can’t just “select from the other side”. I’d have to manually flip the chord stem direction every time to select the bottom notes. Is this expected? Couldn’t there just be an option for “select only the notes in the rectangle”/“ignore stem”? :frowning:

Setting multiple keybinds sound convenient but too tedious for now. I’m having enough problems as is with the default keybinds for almost anything assumes non-nordic keyboards and so, so many things should have to be rebound. (There is no button for = [ or ; etc… It’s pain, or at least annoying to see the menus and documentation refer to these cool shortcuts which are impossible to use.)