Maschine 2 vst2 Not appearing in Plug in Manager

Since Native Instruments upgraded Maschine 2 to vst3 I am have serious CPU load problems - to the point where Cubase splutters, spits and grinds to a halt on projects using Maschine 2 that previously ran okay.

I’m trying to figure out exactly where the problems are by process of elimination, and one avenue I’m trying to explore is to run projects using the vst2 version … but this is no longer appearing on Plugin Manager, just the vst3.

The vst2 dll is still in the Steinberg/Cubase folder, but re-scanning doesn’t find it. I tried copying the dll to a different folder and adding that into the Plugin Manager paths, but still nothing.

Using the latest Cubase update - not sure if this new plugin replacement/update ‘feature’ is playing a part?

Any suggestions would be much appreciated … can anyone else see both vst2 and vst3 versions on their installation?

Maybe try to temporarily move the VST3 to a different folder, so Cubase doesn’t find it it?

That’s because if the software developer (in this case NI), assigns the same ID to the VST2 and VST3 versions of their plugins (and most developers seem to do that now), then Cubase will only enable the VST3 version. So making the VST3 disappear should make the VST2 appear again.

Good call my friend :slight_smile:

I initially tried renaming the vst file but the Plugin Manager refresh still found it ?? Either way, took the file out of the folder altogether, rebooted Cubase and I can now see vst2 only.

Problem is … projects that were previously saved now have an empty instance of Maschine instead of being populated with the kits etc. . I guess I need to see if anyone on the NI community knows how to get both versions available at the same time.

1 Like

I’ve been having similar problems.

Ditching the VST3 version is a good first step. A workaround for the empty Maschine version problem is to save the Maschine project you are working on from the VST3 version inside Cubase. I usually create a Maschine Projects file inside the Cubase project file and whenever I save the Cubase file, drop a copy of the Maschine project as well.

You can then move the Maschine VST3 file again, reload your Cubase project with M-VST2 and just open the Maschine project and all should be as it was before.

Are you running non-NI VST3 plugins inside Maschine in Cubase? I’ve been having trouble with Serum VST3 and some FabFilter VST3, even inside the M-VST2 version, so I’ve been running VST2 inside Maschine where possible and things have been far more stable.

1 Like

That’s a great suggestion - I’ll get that under way and try out a few problematic projects and see how they run. My other thought was to bounce the stems then disable the Maschine track, but that kinda defeats the benefits of the Maschine controller in particular.

I learned pretty quickly that non-NI vsts of either persuasion can cause problems, so I’m tending to avoid using those within Maschine 2 wherever possible.

A real shame - up until the vst3 changeover I had all sorts of stuff running through Maschine, but I’ve had to roll back and mostly stick to the stock FX and instruments. Hopefully your suggestion about saving off the Maschine projects then firing up vst2 will give me back the CPU headroom I’ve lost.

Looks like the problem is Maschine 2 related, but not vst3 particularly.

Just temporarily removed vst3 and booted up Cubase. As before vst2 opens, but empty. Loaded project (saved earlier from vst3 version) but still will not play the project (Using Komplete Audio 6 Mk2 at 256 samples).

Noise, interference and silence after a few seconds as the CPU load goes through the roof.

(BTW, a fairly simple Maschine project without any external vsts involved)

Disable the Maschine track and the project plays fine. I am sending most of the sounds to individual tracks on Cubase - I will try routing everything through the man output and see if that makes a difference.

[Edit] Just tested same project re-routing all the sounds to ‘Group’ and same result, CPU overload stops playing.

However, de-activated all Cubase VSTi outputs - all output now going through Maschine Out 1 (Stereo) and hey presto, project plays without any problem !

Can anyone test this out and see if external routing causes a similar overload?

I just tried it quickly with 7 groups routed to external outputs and it was fine.

A couple of things you can try:

  1. Increase your buffer size.

  2. Avoid having track monitoring or record enable active on the Cubase Maschine instrument track. ASIO guard disables if they are active and that can make a huge difference regarding how much you can run through Maschine before the performance meter is off the scale.

It’s worth noting that Cubase is happiest when you have an even spread of load across a large number of individual tracks, rather than having lots of processing all stacked on a single track.

When running Maschine with multiple internal sound and group channels, all with their own VST instrument and plugin chains it puts far more load on than building a similar project across multiple Cubase tracks.

One way stretching out how far you can go with Maschine is to convert VST patterns to audio loops, delete that VSTs and build groups with Maschine’s internal Audio and Sampler engines.

Using Maschine’s own effects also helps as they are generally more efficient than VSTs (but of course, they may not give you the results you are looking for.)

I agree, the latest combination of C-12 and M-2,16 is not great. I was running C-9.5 and older versions of Maschine since 2018 until last month and it was solid as a rock.

I tend to build the main body of a 7 minute track in Maschine with about 60 or so sounds (all external VSTs (lots of instances of Serum, Kick 2 and the Maschine drum synths + Fab Filter FX)) all running through the Maschine master channel. Then I track the lot though multiple passes onto Cubase audio tracks using the external outputs, through individual group channels onto audio tracks - so each sound from Maschine ends up on it’s own audio track, archive the Maschine project, and do the main mixing work in Cubase before transferring the stereo mix to Wavelab for mastering.

It’s a workflow I’ve been developing for years, so I’m hoping these instabilities calm down over the next few NI and Steinberg updates.

Good luck !!

1 Like

All good info - I’ll try a project with groups as individual outs and see what happens there, but the problem I’m having is with individual sounds sent to external tracks. Maybe that’s a different issue … I’ll experiment further.

The samples problem is what highlighted the issue, I was having to drop down to 2048 to even get the project to play, at 256 it gives up altogether.

Any chance you could load up an empty Cubase project and add an instance of Maschine 2 with a couple of stock kits and compare your Audio Performace meter to mine?

I wouldn’t have expected such a high CPU hit on a single instrument channel?

Before I saw your post above I was just reporting back on a quick test of the Sounds output from this afternoon.

I enabled all 15 additional outputs and routed 15 fifteen sounds from my current Maschine project to them with the rest still on the master. Not all sounds are playing at the same time - but it ran through with no problems.

ASIO Guard, on the Normal setting, shows about 60% in the performance meter. Real Time is about 15-20%. Peak is quite erratic, averaging above 60% with the overload indicator coming on quite frequently, but no breaks or crackles in the audio.

For comparison - I’m running the audio through an older model Scarlet 2i2 with a buffer setting of 128, giving 6.4ms of latency in and out (12.8 total). ASIO Guard is adding another 34.8 ms.

If i switch on track monitoring (i.e. taking Maschine out of the ASIO Guard path) Real Time jumps to 80% and the Peak is bouncing between 95% and overload and the audio starts to crackle. Taking the buffer up to 512 gets rid of the crackles - but Real Time is up at 60%, however, the Peak, although higher is less jumpy.

I’m running an old i7-4790 3.6Ghz with 32GB RAM on Win 10 Pro v21H2 (19044.2251) if that helps.

Many thanks for taking the time out to explore that so thoroughly! Luckily your PC spec is almost identical to mine, so the comparison is more than valid.

So it just seems that Maschine 2 is using a lot more in the way of resouces that it used to - possibly/probably since the move to vst3 ? It uses even more resources using external outs, but it is the overall increase in CPU usage that is the main culprit, with the external outs just pushing Cubase that little bit too far.

I certainly didn’t have so many CPU issues in the recent past. I guess just something I need to be aware of going forward and bounce and freeze more than I used to.

Hopefully someone finds this conversation helpful if they bump the same issues.