Mbox 3 Pro ASIO Driver Not Accepted by Cub7 VST Audio System

Hi everyone,

I’m using an Mbox 3 Pro and trying to get it to play nice with Cubase 7. My driver shows up just fine in the drop down menu for the “VST Audio System” page in Device Setup. However, when I click to use that driver I get the “no hardware found or already in use error message.”

Installed new drivers and updated to version 7.0.5… no luck.

My equipment:

Dell Inspiron N7110
Operating System: Windows 7, 32-bit
Cubase 7 v7.0.5 64 bit
Driver I’m trying to use: Avid Mbox ASIO 64-bit

Works just fine with Ableton Live 9 Standard, so not sure what my issue is. Any suggestions?

Thanks for your time!

You can’t use a 64 bit driver on a 32 bit operating system. Is that a typo? If not, you need to install 32 bit Cubase and get the 32 bit Avid Driver.

I’ve tried using my Mbox ASIO with Cubase 32-bit, and still no success.

It wasn’t a typo, I just knew I could use a 64-bit version of Cubase, but I didn’t know that I couldn’t use 64-bit drivers on a 32-bit system (noob :blush: ).

Hi there,
Avid has created a bad ASIO- driver…so to work-a-round use the
asio4all-driver on windows operating systems for any Avid device (should work with nearly every device):


Best regards,